Closed Bug 358145 Opened 13 years ago Closed 13 years ago

SpellChecker doesn't use xml:lang="en" attribute of inputs to find correct dictionaries

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 338427

People

(Reporter: jp, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1) Gecko/20061010 Firefox/2.0

Inputs with specifics languages may use attributes xml:lang="en", xml:lang="fr", ... The SpellChecker should use this attributes to select the rights dictionary.
This would be very useful for blogs/cms in multiple languages

Reproducible: Always

Steps to Reproduce:
1. Create 2 inputs with attributes xml:lang="en" and xml:lang="fr"
2. Write English text in one and French text in the other
3. Firefox will not use xml:lang attribute to discover the dictionary

Actual Results:  
Firefox will not use xml:lang attribute to discover the dictionary

Expected Results:  
Firefox should select French dictionary for xml:lang="fr" and English dictionary for xml:lang="en". If dictionary is not available, and there is a xml:lang attribute, Firefox should not run Spellchecker on input

*** This bug has been marked as a duplicate of 338427 ***
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.