New mail notification in system tray freezes windows briefly

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
12 years ago
10 years ago

People

(Reporter: kraita, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Thunderbird version 1.5.0.7 (20060909)

Receiving an email freezes windows almost completely (mouse works, explorer won't as well as most applications). This seems to be associated with the notification in the system tray. I removed the sound and the pop-up (leaving only the icon in the tray) and the freeze period got shorter, but it is still noticeable. 



Reproducible: Always

Steps to Reproduce:
1. Enable all notification bells and whistles
2. Receive a mail
3. Try to do something else while the notification appears

Actual Results:  
Impossible to do anything, system appears frozen.

Expected Results:  
The applications should proceed as usual despite the notification being displayed.

In case this is not easily reproducible the bug might have to do with the inbox size (~2500 mails) or the number of imap folders available (dozens, each with thousands of mails).

My system has windows XP, service pack 2 (?), ~1Ghz single processor, 1 gig of ram.

I'm using IMAP, with two different accounts active. I use SSH tunneling to crypt the access to one of the servers.
(Reporter)

Comment 1

12 years ago
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Enable all notification bells and whistles
> 2. Receive a mail
> 3. Try to do something else while the notification appears
> 
> Actual Results:  
> Impossible to do anything, system appears frozen.
> 
> Expected Results:  
> The applications should proceed as usual despite the notification being
> displayed.

One good way to detect the stall is to play music with windows media player when you receive a mail. There is a short break in the music every time a mail arrives.

Comment 2

11 years ago
Still having issue with latest TB? I don't seen such problem with any 2.0.0.x build

Comment 3

10 years ago
RESO INCO per last comment due to lack of response to question. If you feel
this change was made in error, please respond to this comment with your reasons
why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.