Firefox 2.0 does not wrap column info/text onto next line when displaying Invision Power Board forum 2.2 with narrow browser window

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
12 years ago
10 years ago

People

(Reporter: paranoid654321, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/14, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061019 BonEcho/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061019 BonEcho/2.0

FF 2.0 has following problems when displaying Invision Power Board forums, and the IPB developers say it is FF's fault as other browsers display it correctly:

http://forums.invisionpower.com/index.php?autocom=bugtracker&code=show_bug&bug_title_id=3118&bug_cat_id=4

http://forums.invisionpower.com/index.php?autocom=bugtracker&code=show_bug&bug_title_id=3125&bug_cat_id=4

Reproducible: Always

Steps to Reproduce:
I'm using a 1600x1200 resolution

1. Go to http://forums.invisionpower.com/index.php?showforum=296
2. Gradually reduce width of browser window and keep an eye on topics that have multiple pages, indicated by small boxes with page numbers to the right of the topic title.

Actual Results:  
** The topic page indicators will overlap onto the Replies column before it finally wraps onto the next line.

** Also notice how the menu bar at the top right wraps onto the next line at the right, but overlaps the text below.

** Both these problems do not occur on Internet Explorer as it wraps correctly.

Expected Results:  
The topic page number indicators should wrap onto the next line before overlapping onto the Replies column.

The menu bar across the top right should wrap correctly by moving the rest of the page below downwards so as not to overlap.

Check out both problems in IE to see how it should behave properly.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 2.0 Branch

Comment 2

10 years ago
The markup for the "page indicators" looks like this:
<span><a href="">1</a></span>&nbsp;<span>2</span>&nbsp;<span><a href="">3</a></span>&nbsp;...

There is no line break opportunity there.

-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.