If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Links that target _blank always open in new tab, even when preferences set to open in new window

RESOLVED DUPLICATE of bug 358187

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED DUPLICATE of bug 358187
11 years ago
11 years ago

People

(Reporter: Dan Grigsby, Unassigned)

Tracking

2.0 Branch
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

I've set the preferences to open in a new window, not a new tab.  Any link that targets _blank always opens the page in a new tab, not a new window.

Reproducible: Always

Steps to Reproduce:
1. Set preferences to open-in-new-window, not new-tab.
2. Visit, for example, Fark.com where all the links tager _blank
3. Click on any link -- it will open in a new tab, ignoring the setting in preferences

Actual Results:  
Page in new tab

Expected Results:  
Page in new window
(Reporter)

Comment 1

11 years ago
Please disregard the user agent in the report.  It was for the 2.0 release; I switched back to 1.5 because of this behavior, thus the user agent listed in the report.
Version: unspecified → 2.0 Branch

Comment 2

11 years ago
To fix the issue, you'll have to set all pages to open in tabs, confirm the dialog and then set the pref back to what you actually want.

*** This bug has been marked as a duplicate of 358187 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.