Grey padlock on secure web sites not clear enough

RESOLVED INVALID

Status

()

Firefox
General
--
enhancement
RESOLVED INVALID
12 years ago
7 years ago

People

(Reporter: Erlendur S Thorsteinsson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

I don't think that when visting secure web sites (HTTPS) that the grey padlock is clear enough.  Why not use a golden padlock?

Reproducible: Always

Comment 1

12 years ago
that's why the yellow background in the location bar was added
(Reporter)

Comment 2

12 years ago
I use both IE6 and Fx, so I look down to the status bar and expect to find a clearly visible padlock there.  In Fx2 the padlock is grey and not golden (as it was in Fx1) and I always get a momentary feeling that the site is insecure, the cert isn't valid or the content is mixed (especially due to the yellow/black stripe across it).  The golden reddish yellow padlock in Fx1 was much better than the grey padlock in Fx2.

Comment 3

12 years ago
I agree, especially about the "yellow and black stripes" bit.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

12 years ago
In addition, if the page has a mixed secure/insecure content then IE6 and IE7 will not show any padlock icons if you load the insecure content.  (They will only show a padlock icon if only the secure content is loaded; Fx will always load the insecure content; see bug 321022.)

In Fx2, by contrast, a locked padlock with a thin red stripe will be displayed in the address and status bars, although the address bar will not turn yellow.  This striped locked padlock can easily be mistakes for a real locked padlock on a secure site.

The red stripe was more visible on the padlock in Fx1 but it blends in with the padlock in Fx2.  However, I suggest that Fx not show any padlocks on mixed content.  Either the page is secure or it's not.
No padlock anymore, so this gets RESO INVALID.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.