Windows opened from one page are not brought to the front when the same page opens new content in that second window. This worked with previous version of Firefox.

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
11 years ago
8 years ago

People

(Reporter: nigel. d. andrews, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

When a link on one web page opens a new window, that window correctly appears in front of the first. But when another link on that first page is used and it opens the content in the same second window the second window remains behind the first.
In the previous version of Firefox the second window was brought to the front each time a new link was used.

Reproducible: Always

Steps to Reproduce:
1. Select a link which open a second window in front of the first
2. then choose another link in the first which changes the content of the second window
3. see that the second window now remains behind the first.

Actual Results:  
To view the second window, after the contents have been changed, it has to be selected from the task bar to bring it to the front each time.

Expected Results:  
As with the previous version of Firefox the second window is brought to the front each time the contents are changed by select a new link.
Could you tell what link needs to be clicked on the given page to reproduce the problem?
(Reporter)

Comment 2

11 years ago
Yes, if you see a list of programmes, click any programme link to see it's details. That second window will appear ontop, but if you click another program it's details will appear in the second window but that window will not be brought to the front as in previosu versions.

Nigel
(In reply to comment #5)
> O.K. pop-up or new window (different terminology).
> If you call it a 'pop-up' the problem still pertains, that in previous versions
> the 'pop-up' would be brought to the front with each new link that opened new
> content in the 'pop-up'. Now with v2.0 the 'pop-up remains behind even though
> new content is opened ion the 'pop-up'.
> 
> Nigel D. Andrews
> 

OK in that case type about:config in your URLbar and double-click on the line dom.disable_window_flip

In that case type about:config in your URLbar and double-click on dom.disable_window_flip to change the value.
http://kb.mozillazine.org/About:config
Problem is that on http://www.radiotimes.com/PersonalisationServlet?event=8&jspLocation=/jsp/yourprogrammes.jsp&rtError=/jsp/error.jsp&jspError=/jsp/register/index.jsp I don't see any link that opens a new window. When I click on TV (on top) all links I tried only opened pop-ups. Did you try:

- Firefox's safe-mode to exclude extension problems
- a new profile
- a reinstall in a new empty directory ?

http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Folder


(Reporter)

Comment 6

11 years ago
That did the trick thank-you.
(Though I don't remember having to do that with previous versions)

Thanks

Nigel
Please read also Bug 357814, Bug 358580, Bug 355482.
(Reporter)

Comment 8

11 years ago
O.K. pop-up or new window (different terminology).
If you call it a 'pop-up' the problem still pertains, that in previous versions the 'pop-up' would be brought to the front with each new link that opened new content in the 'pop-up'. Now with v2.0 the 'pop-up remains behind even though new content is opened ion the 'pop-up'.

Nigel D. Andrews
So is this a bug or invalid or what?
Version: unspecified → 2.0 Branch
(Reporter)

Comment 10

11 years ago
Being as it is 7 months since the last comment from yourselves I had given up and found a alternative!!!
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.