big jpeg distorts when shrinked from cache

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Dénes Sebestyén, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/14, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; hu; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

I found this problem on a site (www.iwiw.hu), and I reproduced it on my server (because the iwiw needs an account)
On the original site there was a popup where the picture was downloaded first and then a javascript shrinked it to fit in the window. And the shrinked version was fully distorted.
I made the html upper to demonstrate it. If you load it and then press ctrl-r (reload), it will be distorted too
The picture is 842,2 kbytes, it's original size is 2272x1704, after shrinking it's 800x600

Reproducible: Always

Steps to Reproduce:
1. make a html that has a big image in it shrinked
2. load the html
3. reload the html (keep cache on)

Actual Results:  
in the image some of the first columns are okay, but then the last right column repeats

Expected Results:  
show the image well :)

I don't think if there is any special in my browser or my computer. If you can't reproduce it, I'll check it again, or take a screenshot
(Reporter)

Comment 1

12 years ago
Sorry, I sent the bug in a FF 1.5, but it's still a problem with 2.0

Comment 2

12 years ago
I can't reproduce on trunk or Firefox 2 using Linux. Maybe this is Windows only?
Version: unspecified → 2.0 Branch

Comment 3

12 years ago
works for me in Firefox 2 on Mac OS X. Are you using extensions ?
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> works for me in Firefox 2 on Mac OS X. Are you using extensions ?
> 

Maybe I should do the javascript resizing trick too :)
I think it's a windows problem, but I'm listing all my extensions (yeah, I use them): DOM Inspector, FlashGot, IE View, Image Toolbar, Sort Extensions and Themes, Tabbrowser Preferences, Talkback, View Cookies.
Should I try to remove any of them (Image Toolbar is the only one which works with images, but I think it doesn't affect the rendering)
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
(Reporter)

Comment 6

11 years ago
It's okay, thank you
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.