Mail Check problem: Multiple download of same mail

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
12 years ago
2 years ago

People

(Reporter: ganesh.kanchi, Unassigned, NeedInfo)

Tracking

SeaMonkey 1.0 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060910 SeaMonkey/1.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060910 SeaMonkey/1.0.5

If we open the seamonkey mail window mailbox is checked automatically and mail is downloaded. But if we  recheck the mail box by pressing check mail immediately or after sometime the same mail with same time stamp is downloaded again. It vanishes only after checking for two or more times. In short the mail from the mailbox is deleted after it is downloaded multiple times in the local inbox folder. But the mail should have been deleted the first time itself. Also the auto check mail every fixed interval does not seem to work unless the mail window is left open. In earlier versions of Mozila you can close the mail window and left the browser window open for auto checking mail to work.

Reproducible: Always

Steps to Reproduce:
1.Start a Seamokey mail window(with mail account configured to delete the mail from mailbox immediately after download)
2.Configure Seamonkey to check mail for every five minutes and leave it open. Alternatively Click on Get message tab multiple times.

Actual Results:  
Mailbox is checked and the new mails are downloaded.Click the get message tab for a couple of times and you will find multiple copies of the same mails are downloaded for atleast a couple of times and sometimes even four copies.
The situation is worse if you have configured the seamonkey to check for every 5 minutes or so and left open for a period of time(say 15-20) minutes. To prevent it mail has to be checked manually by clicking get message tab as soon as the first copy is downloaded then you will have two copies of the same mail in your mail box otherwise prepare for multiple copies.

Expected Results:  
Mail is downloaded to the local inbox folder and the mail is deleted from the Mail site Mail box. No multiple copies of the same mail unless the sender has sent it multiple times.

Please impart something which would enable the seamonkey to check mail if email Id and password is saved even when the seamonkey window is not left opened. Ideally the Seamonkey should ask the user to download messages if it finds any new messages in the mailbox of the mail site.

Comment 1

12 years ago
This is a gmail.com POP3 account or another provider?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> This is a gmail.com POP3 account or another provider?
> 

pop 3 account from another provider

Comment 3

12 years ago
I've found that particular emails I'm trying to download from Yahoo! via POP3, are not liked by Mozilla and it consistently stops on such emails. Since it didn't complete the download, it starts all over again the next time I try (I think Mozilla was locking up at that point) it's duplicating the messages. Deleting the offending email (via webmail) allows Mozilla to finish.

Does this ring any bells?
SeaMonkey v1.0.x is not supported anymore.

Can you reproduce with SeaMonkey v1.1.9 ?
Version: unspecified → SeaMonkey 1.0 Branch
(Reporter)

Comment 5

11 years ago
I have reported this bug long back. I have tried the same thing on the release next to the one I have reported also. But found the same problem. Hence shifted to Thunderbird and Firefox. Will check with the latest version of seamonkey and get back.

Comment 6

11 years ago
Serge, I've attempted to download some of the offending emails (that I still had on the server) and did not have a problem downloading them.

Comment 7

10 years ago
Same case happen to my Thunderbird.

Comment 8

2 years ago
Still reproducible for someone?
Flags: needinfo?(ganesh.kanchi)

Comment 9

2 years ago
Seems not, so I close this one for now, I never observed this problem.
@Reporter: Please feel free to reopen this Bug if you still can reproduce the problem with a current SeaMonkey version and a current OS and if you can contribute a step by step instruction how to reproduce the problem due to <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>  (containing every key press and every mouse click) how to reproduce the problem reliably.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.