Saves only first 7 characters of username

RESOLVED WONTFIX

Status

()

Toolkit
Password Manager
--
minor
RESOLVED WONTFIX
12 years ago
10 years ago

People

(Reporter: russ francis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

For this URL only, just the first 7 characters of the saved username appear in the box, and login doesn't work. (However, the full username appears in Password Manager.) Once the full username is entered, login works. But rebooting or moving to another URL and then returning creates the same problem.


Reproducible: Always

Steps to Reproduce:
1. Go to http://spider.gvpl.ca/proquest_login.html
2. Enter username and password and login. Then exit the URL.
3. Return to http://spider.gvpl.ca/proquest_login.html

Actual Results:  
Same problem

Expected Results:  
Should save username after it's entered once.
That's because bug 270558 means we don't replace the seven digits that are common to every barcode, that they prefill, because we can't tell that it's not something like an admin "change user password" page where they prefilled another username that you are going to change. You can work around it by clicking the username box, hitting down-arrow and selecting your saved barcode from the autocomplete menu, then tabbing out, at which point the password will be filled in. Fixing it, I'm not so sure about: I doubt that "prefilled with a prefix that's common to all usernames" is widespread enough to make it worth having pw manager check whether what the page prefilled is the starting substring of a saved username, and I suspect there would still be cases where replacing would be wrong (the admin "foobar" trying to make changes to the user account "foob").
I agree with the last comment. Closing as WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.