Last Comment Bug 358560 - Canvas2D renders black with 16M colors on OS/2
: Canvas2D renders black with 16M colors on OS/2
Status: VERIFIED FIXED
: verified1.8.1.1
Product: Core Graveyard
Classification: Graveyard
Component: GFX: OS/2 (show other bugs)
: Trunk
: x86 OS/2
: -- normal (vote)
: ---
Assigned To: Peter Weilbacher
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-28 16:42 PDT by Peter Weilbacher
Modified: 2009-01-22 10:18 PST (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
add pixel format for BGR_A8 (1.58 KB, patch)
2006-10-28 16:59 PDT, Peter Weilbacher
abwillis1: review+
mozilla: superreview+
dveditz: approval1.8.1.1+
Details | Diff | Review

Description Peter Weilbacher 2006-10-28 16:42:52 PDT
As noted in the newsgroup the canvas that is created by the Firefox Showcase extension or the SeaMonkey tab preview tooltips displays black when the system is set to 16M colors with the SNAP driver. With the 64K colors setting it displays just fine.
Comment 1 Peter Weilbacher 2006-10-28 16:59:44 PDT
Created attachment 243934 [details] [diff] [review]
add pixel format for BGR_A8

The problem is simply because nsOffscreenSurface::GetPixelFormat() does not implement 32bit depths, just 24bit depth. I don't know why SNAP implements 16M colors as 32bit instead of 24bit but this patch seems to fix the problem here. It implements 32bit as BGR_A8 which is what OS/2+SNAP seems to be using (at least that is the format that always worked in the SVG code). It uses basically the same bit masks as GetPixelFormat() on Windows.

Andy, would be great if you could confirm that this patch fixes the problem for you, too.
Comment 2 Andy Willis (abwillis) 2006-10-28 19:38:49 PDT
Comment on attachment 243934 [details] [diff] [review]
add pixel format for BGR_A8

Works like a charm.
Comment 3 Mike Kaply [:mkaply] 2006-10-29 05:21:09 PST
Comment on attachment 243934 [details] [diff] [review]
add pixel format for BGR_A8

sr=mkaply (OS2 only)
Comment 4 Peter Weilbacher 2006-10-29 10:37:45 PST
Fix checked into trunk (with an additional "break;" that was missing from the patch).
Comment 5 Peter Weilbacher 2006-11-07 15:19:51 PST
Comment on attachment 243934 [details] [diff] [review]
add pixel format for BGR_A8

Would be great to get this OS/2 only, trunk tested fix into 1.8 branch.
Comment 6 Daniel Veditz [:dveditz] 2006-11-29 11:44:11 PST
Comment on attachment 243934 [details] [diff] [review]
add pixel format for BGR_A8

approved for 1.8 branch, a=dveditz for drivers
Comment 7 Peter Weilbacher 2007-03-11 14:54:50 PDT
Verifying some older bugs.

Note You need to log in before you can comment on or make changes to this bug.