invisible gmail chat messages that were received while not in gmail tab

RESOLVED INCOMPLETE

Status

()

Firefox
Tabbed Browser
RESOLVED INCOMPLETE
12 years ago
9 years ago

People

(Reporter: milos.rasic, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-05-24, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Bug occurs when I have more than one tab open and one of them is Gmail with Gmail Chat active. If anyone sends me a message while I'm looking at some other tab, no notification sound plays and when I go back to Gmail tab the message I just received is not visible. If the chat box was not open, it will pop up as it should, but the message is still invisible. This bug does not occur in versions prior to 2.0 and in latest build Minefield. I have friends who got Gmail to work correctly in FF2 in the same circumstances, but I also found some FF2 users who have the same problem as I do.

Reproducible: Always

Steps to Reproduce:
1. Open Gmail, log in and enable Gmail Chat.
2. Open any other site in another tab.
3. Go back to Gmail tab and ask someone to send you a message. Quickly switch to the other tab (before the message arrives).
4. Give your friend enough time to send you a message and then return to Gmail tab.
5. The message will not be there. If you closed the chat box it will pop back up but there will be no new message in it. You can see the invisible message with "recent conversations" option.

Actual Results:  
The message doesn't display in the chat box.

Expected Results:  
The message should display in chat box.

I used default theme and I have no other themes installed. I have the latest versions of following add-ons installed: DOM Inspector, FlashGot, Gmail Notifier, IE Tab, PDF Download, SearchPluginHacks (not compatible), SearchStatus, Web Developer

Comment 1

9 years ago
still see this problem when using FF 3.5 beta (or 3.0?)
 http://www.mozilla.com/en-US/firefox/all-beta.html
Component: General → Tabbed Browser
Whiteboard: closeme 2009-05-24
Please reopen this bug if it appears with a recent version of firefox 3 in a new profile. http://support.mozilla.com/kb/Profiles
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
QA Contact: general → tabbed.browser
You need to log in before you can comment on or make changes to this bug.