Middle clicking sometimes goes to top of page instead of opening a new tab

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Nicolas Kyriazopoulos-Panagiotopoulos, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/14)

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

When I middle click on a link, sometimes instead of opening a new tab, it gets me to the top of the page.
I suppose that (some kinds of links? I haven't found if there's something different with them) the active area of some links is too small and a slightly unfocused click has this strange behavior.

Reproducible: Sometimes

Steps to Reproduce:
I cannot willingly reproduce it, but it happens more often when I pay less attention to focusing. I didn't have this problem with any previous firefox version or any other application.
Actual Results:  
I went to the top of the page.

Expected Results:  
The link should open into a new tab.

Microsoft optical wheel mouse (configured: speed medium, double click speed medium)

Comment 1

11 years ago
Metoo: I also experienced this problem.

It happens very intermittent; after being taken to the top of the page, scrolling back down to the link and middle-clicking again opens up the new tab. I also experienced this phenomenon on a drop-down list box (with some JavaScript in the back) once.

System:
Browser: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Addons: Adblock 0.5.3.043, DictionarySearch 2.0; DOM Inspector 1.8.1; ForecastFox 0.9.3.1; Greasemonkey 0.6.6.20061017.0; Groowe Search Toolbar 1.5.0; ShowIP 0.8.05; UrlParams 2.01.01; View Cookies 1.6; View Source Chart 2.4.05.
OS: WinXP (2002) SP2

Comment 2

11 years ago
After using Firefox some more, I have noticed that this happens with all sorts of events: Normally clicking on links, checkboxes, buttons, even empty space next to a page's text.

I would hazard the guess that it has to do with the action of clicking rather than something in the HTML/other web page contents.

Still no idea how to reproduce this, though....

Comment 3

11 years ago
I have noticed that, intermittently, when I left click on a link, I am taken to the top of the current page.

If I scroll back down to the link and try again, it usually works.

I have also noticed this occurring on form fields, such as check boxes, as well as links. In fact, the first time I noticed it with a check box was on a bugzilla page - I clicked the "Add xxxxxx to CC list" check box and it jumped to the top of the page.

I scrolled back down and clicked the check box and it worked.

This is a bit more than just annoying, it is incorrect behavior and it needs to be fixed.

I have only noticed this since upgrading to 2.0 (2.0 seems to have far too many bugs, minor or major)

While this may not be truly reproducible, the bug exists and needs to be run down and fixed.

I've seen it on Window 98SE - that is the only system on which I have Firefox installed - and since it was originally reported on XP, this is not a OS dependent bug.

Bob Novell

Comment 4

11 years ago
I've noticed this as well... it's incredibly annoying when you are in the middle of a longer page and suddenly find yourself at the top (digg.com would be a good example). I don't remember seeing this before 2.0.

If anything, the severity of this bug should be increased, as is is a pretty major annoyance.

Comment 5

11 years ago
Created attachment 249387 [details]
HTML document which will reliably cause the scrolling bug

The attached html document (scrollproblem.html) is the first one I have come across which can reliably cause this problem. To cause the bug to occur, open a new instance of Firefox, or at least a new tab. Resize the window to about 640x480 (small enough that the page will be forced to v-scroll). Drag the file from wherever you saved it and drop it into the blank open window (File-> Open will sometimes cause the bug to not appear). Now scroll to the bottom without clicking anything. Now click dead center in the third option from the bottom in the first column. If everything works (it happens 100% of the time on my machine), you will be scrolled to the top of the page.

Comment 6

11 years ago
Possible solution: 
-In about:config
   -toggle 'accessibility.browsewithcaret' to false.
 
This fixed the scrolling problem in the above attachment.
Reporter, do you still see this problem with the latest Firefox 2 and the info in comment 6? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 2.0 Branch
(Reporter)

Comment 8

11 years ago
ok, it's been a while since i noticed this happening, so I suppose it was fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.