Bookmark Manager bug when drag dropping folders

VERIFIED INVALID

Status

()

Firefox
Bookmarks & History
--
critical
VERIFIED INVALID
11 years ago
11 years ago

People

(Reporter: Mark Wiltshire, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1) Gecko/20061010 Firefox/2.0

This has happened twice to me now and is very annoying.
When I am re-organising my bookmarks in bookmark manager, I drag and drop a folder in the right hand pane to a new location.  But this deletes another folder ? I have just lost all my development links, over 40 links.  It has just happened again when the single item I was moving, has overwritten the Quick links Folder of links.  ???

Can you please fully test this it should never delete an item !!!!

Reproducible: Always

Steps to Reproduce:
1. start bookmark manager
2. start re-organising your items
3. **** !!!
There's a set of bookmark backups in your profile folder.
I never saw this problem, at least not in the Manager.

Comment 2

11 years ago
This works for me, as well.

Reporter, do you have any extensions installed?

see: http://kb.mozillazine.org/Lost_bookmarks for help recovering your bookmarks.
(Reporter)

Comment 3

11 years ago
Hi there, 

Yep I have the following extensions / addons

cookieSafe 1.1.5
CSS validator 0.3
DOM Inspector 1.8.1
Download Embedded 0.5
Downlaod Statusbar 0.9.4.5
Duplicate Tab 0.8.1
Fasterfox 2.0.0
Firebug 0.4.1
Google Browser Sync 1.3 20061031.0
Google Toolbar for Firefox 2.1.20060807
Html Validator 0.7.9.5
IE Tab 1.1.1.4
Image Zoom 0.2.7
JavaScript Debugger 0.9.87
Last Tab 2.0.5
NewTabeURL 1.2.6
NoScript 1.1.4.5.061030
Remove Cookie(s) for Site 0.3
Server Spy 0.1.2
Server Switcher 0.4
ShowIP 0.8.05
Talkback 2.0
TAW3 en un clic 0.9.5
Web Developer 1.0.2

I haven't tried again as I do not want to loose any more bookmarks.
This is the new version 2.0 of Firefox.

Regards

Mark

(Reporter)

Comment 4

11 years ago
I have updated a lot of the add/ons since this happened, have just tried to re-create error and cannot, moving folders and bookmarks about in the bookmark manager all works fine now.

Can close.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Probably an extension bug then, so the correct resolution is INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → INVALID

Comment 6

11 years ago
reporter, thank you for your quick and informative response.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.