If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

spell check do not handle multilingual values

RESOLVED DUPLICATE of bug 339574

Status

()

Toolkit
Form Manager
RESOLVED DUPLICATE of bug 339574
11 years ago
9 years ago

People

(Reporter: Artem Skoretskiy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1) Gecko/20061010 Firefox/2.0

When words in different languages are entered into single text field with spell check enabled, spell check cannot handle it.

Reproducible: Always

Steps to Reproduce:
0. Ensure that all needed dictionaries are installed (ex. Russian and English)
1. Type word in different languages into the same text field (ex. Russian and English)
2. Select one of the dictionaries for spell check in the text fields (ex. Russian).
3. See the result.
4. Select other dictionary (ex. English)
5. See the result
Actual Results:  
Words in language other than current dictionary selected for spell check in the field, are marked as misspelled.

Expected Results:  
Words in all languages that are spelled right, are not marked as misspelled.

*** This bug has been marked as a duplicate of 339574 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.