If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

suggestion to have a link to open bookmarks in a folder in new tabs

RESOLVED DUPLICATE of bug 216346

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED DUPLICATE of bug 216346
11 years ago
11 years ago

People

(Reporter: Amr Hamdy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

I want to have a link in the bookmark folders to open the bookmarks in new tabs?
Why when I open bookmarks with "Open All in Tabs" link I lose my currently opened tabs?
Why don't it open in new tabs by default? I think it's more logic that it open in new tabs other than overriding my opened tabs !!
why would I have to open a new window then "Open All in Tabs" to get bookmarks opened without losing my currently opened tabs?
What if I've too many bookmarks in a folder so I cannot right click on every bookmark and "open in a new tab"?? should I open a new window then? I think opening a new window for that will make the great "tabbed browsing feature" of Firefox less useful ...

Thanks very very very much for you great efforts :) ! 

Reproducible: Always

Steps to Reproduce:
1.Open some pages in multiple tabs
2.Open a bookmark folder an click on "Open All in Tabs"


Actual Results:  
You will lose your currently opened pages ... :(

Expected Results:  
Open the bookmarks in new tabs and never override my currently-opened tabs

Comment 1

11 years ago
Set browser.tabs.loadFolderAndReplace to false in about:config - http://kb.mozillazine.org/Browser.tabs.loadFolderAndReplace
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> Set browser.tabs.loadFolderAndReplace to false in about:config -
> http://kb.mozillazine.org/Browser.tabs.loadFolderAndReplace
> 
Thanks very very much for you kind help :)
Nice option! but even if that option exists it should be setted to false by default! for all the reasons that I mentioned and others too ... maybe you can do a poll on that ...
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 3

11 years ago
I've read this bug page ..
https://bugzilla.mozilla.org/show_bug.cgi?id=173406
But I can be sure that more than 70% of users would like that issue to be "false" by default ...
I think if making a poll is possible .. we can see then .. :)
Thanks again 
Surprisingly enough, this isn't the first time this has come up.

*** This bug has been marked as a duplicate of 216346 ***

*** This bug has been marked as a duplicate of 216346 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE

Comment 5

11 years ago
And surprisingly, these kind of bugs are constantly closed instead of just changing the default to a non-destructive behaviour. Why do you think lots of lots of people still report this? (three new duplicates in the last week).
You need to log in before you can comment on or make changes to this bug.