Selecting 'Show a blank page' or 'Show my windows and tabs from last time' doesn't disable the Home Page text box

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: maxozilla, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Selecting 'Show a blank page' or 'Show my windows and tabs from last time' from the pull-down menu in the Options window under 'Main' should disable the Home Page text box, since it isn't needed when either of these options is selected. It should only be active when 'Show my home page' is selected from the pull-down menu.

Steps to reproduce:
1. Go to Tools, Options
2. Select either 'Show a blank page' or 'Show my windows and tabs from last time' from the 'When Firefox starts' pull-down menu.
3. The 'Home Page:' text box isn't disabled. It should be.
Selecting either of those options only controls what occurs at startup - not what happens when the user presses the Home button or if a script calls window.home(). So even if the user selects a startup option, they still need to be able to set a homepage.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.