crash using DOM Inspector "Find node by clicking" tool

VERIFIED INVALID

Status

()

--
critical
VERIFIED INVALID
12 years ago
12 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

1.8 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061029 BonEcho/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061029 BonEcho/2.0

crash when clicking near the top of a Bugzilla page (a few millimeters under the red dragon) with the DOM Inspector "Find node by clicking" tool

Reproducible: Didn't try

Steps to Reproduce:
1. Open Bugzilla bug page
2. Open DOM Inspector
3. Click the "Find node by clicking" tool at top left in Inspector window
4. Click below the red dragon at top left in Bugzilla page
Actual Results:  
crash

Expected Results:  
no crash

Additional info: TB25229309X

Incident ID: 25229309
Stack Signature	nsBindingManager::GetContentListFor() 8b7d2ffd
Product ID	Firefox2
Build ID	2006102901
Trigger Time	2006-10-29 16:34:22.0
Platform	LinuxIntel
Operating System	Linux 2.6.11.4-21.14-default
Module	firefox-bin + (003d1e7a)
URL visited	https://bugzilla.mozilla.org/show_bug.cgi?id=358659
User Comments	Clicking near the top of the page with the DOM Inspector's "eye" tool
Since Last Crash	0 sec
Total Uptime	0 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	/builds/tinderbox/Fx-Mozilla1.8/Linux_2.4.21-27.0.4.EL_Depend/mozilla/content/xbl/src/nsBindingManager.cpp, line 848
Stack Trace 	
nsBindingManager::GetContentListFor()  [mozilla/content/xbl/src/nsBindingManager.cpp, line 848]
libinspector.so + 0x5d08 (0x415d0d08)
libinspector.so + 0x596b (0x415d096b)
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode)()  [mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2168]
XPC_WN_CallMethod()  [mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 1455]
js_Invoke()  [mozilla/js/src/jsinterp.c, line 1377]
js_Interpret()  [mozilla/js/src/jsinterp.c, line 4122]
js_Invoke()  [mozilla/js/src/jsinterp.c, line 1396]
nsXPCWrappedJSClass::CallMethod()  [mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 1415]
nsXPCWrappedJS::CallMethod()  [mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 468]
PrepareAndDispatch()  [mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_gcc_x86_unix.cpp, line 100]
nsEventListenerManager::HandleEventSubType()  [mozilla/content/events/src/nsEventListenerManager.cpp, line 1655]
nsEventListenerManager::HandleEvent()  [mozilla/content/events/src/nsEventListenerManager.cpp, line 1056]
nsDocument::HandleDOMEvent()  [mozilla/content/base/src/nsDocument.cpp, line 4046]
nsGenericElement::HandleDOMEvent()  [mozilla/content/base/src/nsGenericElement.cpp, line 2183]
nsGenericElement::HandleDOMEvent()  [mozilla/content/base/src/nsGenericElement.cpp, line 848]
nsGenericElement::HandleDOMEvent()  [mozilla/content/base/src/nsGenericElement.cpp, line 848]
nsGenericElement::HandleDOMEvent()  [mozilla/content/base/src/nsGenericElement.cpp, line 848]
nsGenericElement::HandleDOMEvent()  [mozilla/content/base/src/nsGenericElement.cpp, line 848]
PresShell::HandleEventInternal()  [mozilla/layout/base/nsPresShell.cpp, line 848]
PresShell::HandleEvent()  [mozilla/layout/base/nsPresShell.cpp, line 6260]
nsViewManager::HandleEvent()  [mozilla/view/src/nsViewManager.cpp, line 848]
nsViewManager::DispatchEvent()  [mozilla/view/src/nsViewManager.cpp, line 2246]
HandleEvent()  [mozilla/view/src/nsView.cpp, line 251]
nsCommonWidget::DispatchEvent()  [mozilla/widget/src/gtk2/nsCommonWidget.cpp, line 219]
nsWindow::OnButtonPressEvent()  [mozilla/widget/src/gtk2/nsWindow.cpp, line 1655]
button_press_event_cb()  [mozilla/widget/src/gtk2/nsWindow.cpp, line 3830]
libgtk-x11-2.0.so.0 + 0x11b81e (0x402f081e)
libgobject-2.0.so.0 + 0x78db (0x405978db)
libgobject-2.0.so.0 + 0x16d8b (0x405a6d8b)
libgobject-2.0.so.0 + 0x17ff2 (0x405a7ff2)
libgobject-2.0.so.0 + 0x18626 (0x405a8626)
libgtk-x11-2.0.so.0 + 0x202f14 (0x403d7f14)
libgtk-x11-2.0.so.0 + 0x1152f9 (0x402ea2f9)
libgtk-x11-2.0.so.0 + 0x11674f (0x402eb74f)
libgdk-x11-2.0.so.0 + 0x3ded2 (0x404daed2)
libglib-2.0.so.0 + 0x23967 (0x405eb967)
libglib-2.0.so.0 + 0x25ce2 (0x405edce2)
libglib-2.0.so.0 + 0x26cf7 (0x405eecf7)
libgtk-x11-2.0.so.0 + 0x116be3 (0x402ebbe3)
nsAppShell::Run()  [mozilla/widget/src/gtk2/nsAppShell.cpp, line 141]
nsAppStartup::Run()  [mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
XRE_main()  [mozilla/toolkit/xre/nsAppRunner.cpp, line 2440]
main()  [mozilla/browser/app/nsBrowserApp.cpp, line 62]
libc.so.6 + 0x14e80 (0x40a60e80)
changing "version" in the heading. This isn't a "trunk" build. Dunno if Fx 2.0 (Gecko 1.8.1) qualifies as "1.8 branch" which I would use for Fx 1.5.0.x (Gecko 1.8.0.x). Setting "Other Branch" for lack of something I can be sure of. Gurus, feel free to change it again: version to 1.8 or All or ..., maybe Platform to All/All: I notice DOM Insp. crashes on W32 which have been resolved WORKSFORME. It sure didn't work for me this time -- but I'm on Linux.
Version: Trunk → Other Branch

Comment 2

12 years ago
Looks similar to Bug 344396?
(In reply to comment #2)
> Looks similar to Bug 344396?
> 

Well, maybe, but bug 344396 has been "fixed1.8.1" since 2 September, while this happened to me yesterday (29 October) on the latest 1.8.1 nightly.
Firefox 2 == 1.8 branch.

WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061026 SeaMonkey/1.5a, so it almost certainly isn't a trunk problem.
(In reply to comment #4)
> Firefox 2 == 1.8 branch.

Hm. OK, let it be so. Any idea why the drop-down here at top makes no difference between 1.8.0 branch (Fx/Tb 1.5.0.x) and 1.8(.1) branch (Fx/Tb 2)?
Version: Other Branch → 1.8 Branch

Comment 6

12 years ago
because gecko isn't supposed to change significantly on branches.

Comment 7

12 years ago
tbat said, afaik libinspector.so isn't supposed to exist anymore.
(In reply to comment #7)
> tbat said, afaik libinspector.so isn't supposed to exist anymore.
> 

I see it in /usr/local/firefox/inspector@mozilla.org/components but not in the tarball. I'll try a "clean" install, i.e.

    rm -Rvf /usr/local/firefox
    tar -xvC /usr/local firefox-2.0.en-US.linux-i686.tar
(In reply to comment #8)
[...]
>     tar -xvC /usr/local firefox-2.0.en-US.linux-i686.tar
oops --------------------^
I mean -f
Let's assume it was due to failing to remove the obsolete libinspector.so
=> RESO INVA

Anyone sees this bug, please speak up.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.