erasing text while adding an entry in address book enlarges gnome-panel

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: IcedSoal, Assigned: scottputterman)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
ok this is really weird, but i'll try to explan it.  i click "new card" in my
address book and start adding, then i erase, and everything's all right right up
until i deleted the last character in the "First:" "Last:" or "Display:" field

for example if i was making an entry for myself and i typed "IcedSoal" in the
"First:" field as my first name, then i decided i wanted to erase that, i can
hit backspace all i want but as soon as i delete the "I" in "IcedSoal" hence
making the "First:" field empty my gnome panel immediately expands to about 3 or
for times it's normal height becoming quite an eyesore on my screen, if i close
the address entry i was editing by hitting "Ok" or "Cancel" then gnome-panel
goes right back it's normal height.  i tested all the fields in the new card
dialog and the only fields that create this bug w/ gnome-panel when you erase
your input completely to zero are the "First:" "Last:" and "Display:" fields,
all the other fields can be erased to no input w/ no problem... sorry for
writing so much but i think that explains it... i'm using build 2000041409

Updated

19 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: lchiang → esther

Comment 1

19 years ago
Mass move mailnews bugs to Putterman.  Ouch.
Assignee: hangas → putterman
(Assignee)

Comment 2

19 years ago
I haven't tried this on Linux yet, but is this still happening?
Status: NEW → ASSIGNED
Target Milestone: --- → M18
(Reporter)

Comment 3

19 years ago
no it doesn't do it anymore, if your at the end of text hitting the cursor will

remain where it is no matter how many times u hit the right arrow, but if you're

on a new line (after hitting enter) hitting the right arrow key produces the

following error message in the console



JavaScript error:

 line 0: uncaught exception: [Exception... "Component returned failure code:

0x80004003 (NS_ERROR_INVALID_POINTER) [nsIController.doCommand]"  nsresult:

"0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: <unknown

filename> :: onkeypress :: line 0"  data: no]



i'm using build 20000428309

(Assignee)

Comment 4

19 years ago
marking WFM since the main bugs seems to be fixed now.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 5

19 years ago
Verfified original bug as worksforme per comment from reporter.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.