If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Yellow column (includes cnn.com section) at Netcenter doesn't show up in mozilla

VERIFIED INVALID

Status

()

Core
Layout
P3
normal
VERIFIED INVALID
18 years ago
16 years ago

People

(Reporter: Douglas Lee, Assigned: rickg)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; m14)
BuildID:    2000041308

I loaded up http://home.netscape.com, and it automatically redirected me to
http://home.netscape.com/index1.html -- I assumed it's because my mozilla
profile didn't include the "cookie" which tells Netcenter that I've got a
Netcenter account there...  Anyway, when the page was finished loaded, I found
that the far left column that includes the Latest News from cnn.com, Weather
Search, etc. didn't appear in mozilla.  I went back to 4.72 and loaded up the
page, making sure that I signed out of Netcenter and reloaded the same URL.
4.72 shows that column.

Reproducible: Always
Steps to Reproduce:
1. load url http://home.netscape.com, making sure that you are not signed into
Netcenter.  it should redirect you to index1.html
2.
3.

Actual Results:  The yellow column which contains the Latest News from cnn.com,
Weather Search, etc. that is normally visible in 4.72 does not show up in mozilla.

Expected Results:  That column should be there.

I signed out of Netcenter in my 4.72 profile to make sure that both the mozilla
and 4.x profiles were at least identical on this particular front.  I tried
checking the html source using mozilla but without a Find command in viewing the
source (might look up the bugzilla db to see if that's a feature in progres...),
I really couldn't tell whether mozilla had picked up the html source which
contains that cnn.com column.

Comment 1

18 years ago
Tested with 2000-04-14-09-M16 and NN4.72; this does not appear to be a layout 
problem at all.

If either http://home.netscape.com/index1.html or
          http://home.netscape.com/
is loaded by Mozilla, the first is displayed in the URL bar and the
corresponding page is loaded. If either URL is loaded by NN 4.72,
the second URL displayed in the URL bar and the corresponding page is loaded.

It would appear that Netcenter is providing a distinct front page to Mozilla.
Circumstantial evidence -- the way that the grey part of index1.html
blends into the bottommost Mozilla toolbar -- seems to bear that out.
Also, index.html is 9k larger than index1.html.

Comment 2

18 years ago
http://home.netscape.com/index.html contains:

parseFloat(navigator.appVersion)>=5)&&((navigator.appName=="Netscape")||(navigator.appName=="Mozilla"))){location.href="http://home.netscape.com/index1.html";}

That is: if it's Mozilla 5, go to index1.html. 

So Sean is exactly right and the is not a bug.  Netscape is serving different
content to NN 4.x and Mozilla 5/NN 6.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 3

18 years ago
... and index1.html correspondingly points older browsers back to index.html.

D'oh! You'd think with all that indirect evidence I'd try looking for direct
evidence... marking VERIFIED.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.