Bug in ordering of Go menu and History sidebar entries

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED INVALID
12 years ago
10 years ago

People

(Reporter: w4zsvryct5gx7nf, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060913 Fedora/1.5.0.7-1.fc5 Firefox/1.5.0.7 pango-text
Build Identifier: Mozilla/7.0 (X12; U; Linux i987; en-IE; rv:4.7.1) Gecko/20110415 Firefox/7.0.2

I would like to have the entries in the history panel ordered by last visit. Currently the closest to this is ordering by first visit, which makes little sense.

The logic can be understood when you observe how you naturally organise books on the desk you have been reading.

To go further I think this should be the default.


Reproducible: Always

Steps to Reproduce:
1. open history panel
2. go to foo.com
3. go to bar.com
4. go to qux.com
5. go to bar.com again


Actual Results:  
History panel:
qux.com
bar.com
foo.com

Expected Results:  
History panel:
bar.com
qux.com
foo.com

Tested on both Firefox 1.5 and 2.0
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061029 BonEcho/2.0

When you close and open the panel the last visited site appears on top.
The same happens with the go-menu but only after a browser restart.
Whiteboard: [DUPEME]
(Reporter)

Comment 2

12 years ago
I was testing this a bit more, and not even browser restart is needed; Closing a browser window also fixes up the history list.
So this looks like the intended behaviour is what I would like to see, and it's just a simple bug.
OS: Linux → All
Hardware: PC → All
(Reporter)

Updated

12 years ago
Summary: History panel ordering should be more logical → Bug in ordering of Go menu and History sidebar entries (Was: History panel ordering should be more logical)
(Reporter)

Updated

12 years ago
Summary: Bug in ordering of Go menu and History sidebar entries (Was: History panel ordering should be more logical) → Bug in ordering of Go menu and History sidebar entries
Version: unspecified → 2.0 Branch
(Reporter)

Updated

12 years ago
Severity: normal → major

Comment 3

11 years ago
Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.9a8pre) Gecko/2007082112 Minefield/3.0a8pre

This bug can be reproduced for Firefox2.0.0.6 but can not be reproduced for Firefox3.0 trunk build on Solaris11

Comment 4

11 years ago
Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.1.6) 
Gecko/20070814 Firefox/2.0.0.6
The bug cannot be reproduced.

Because the same website name is only recorded once, everytime after I visit the UTL which is already in the history list, I have to refresh the URL order manually.

Steps:
note: visit the website in a same tab.
Select History View as "By last visited"
1.visit yahoo.com
2.visit google.com
3.visit yahoo.com
4.click "view" on the History panel, select other order and then select"By last visited" again.

Actual result:
On the History panel:
After#1:yahoo.com is on the top
After#2:google.com is above on yahoo.com
After#3:The same as After#2
After#4:yahoo.com is on the top and google.com is below it.

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks

Comment 5

10 years ago
not going to fix this on 2.x anymore, but feel free to reopen if the bug is still visible on current trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.