Input field losing focus when other tab doing a refresh

NEW
Unassigned

Status

()

Core
DOM
11 years ago
6 years ago

People

(Reporter: Yo-han, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

I have a few tabs open here. In one is a site which has a meta refresh element so this page is refreshing every minute. When I'm editing a input field or textarea in another tab and the page with a js command window.setTimeout("self.location='<url>';", 30000); is refreshing it looks like the input is losing his focus. 
I have to choose another field, edit that one en return to the first input field to continue editing my text.

For additional info, please email me.

Reproducible: Always

Steps to Reproduce:
1.one page with reload command (window.setTimeout("self.location='<url>';", 30000);). one page with html input form.
2.both open in a tab.
3.start editing the form till the other tab will do a refresh.

Actual Results:  
no characters appear in the input field anymore

Expected Results:  
characters in the input field

page 1 is a frameset with a reload script in on of the frames.
window.setTimeout("self.location='alert.php?forcereload=1162309800';", 30000);

page 2 can be every page with a form.
(Reporter)

Comment 1

11 years ago
It also happens in the address bar. Every field where input is possible stops working after the refresh is your typing in it. After a few clicks outside the input field you can typ again.
This is worksforme.
Maybe you could give an url that shows the problem or something?
I at least couldn't reproduce it with the example I made.
(Reporter)

Comment 3

11 years ago
the page with the refresh contains 2 frames. One of the frames contians a iframe which includes a page from another server. That page contains the code:

[code]
<HTML><HEAD><script>window.setTimeout("self.location='alert.php?forcereload=1163435986';", 30000);</script><style>body,table{font-family:arial;font-size:12px;color:white;}</style></HEAD><body margins=5 bgcolor=#564BBA><embed width=0 height=0 src=alert.wav></embed><a target=main href='<url>=18'>
....
</body>
</html>
[/code]
Created attachment 245582 [details]
wav file needed for testcase

Thanks for the explanation, now I can reproduce the bug.
It has to do something with the embed which is handled in my browser by the Quicktime plugin.
Created attachment 245583 [details]
testcase
Created attachment 245584 [details]
testcase
Attachment #245583 - Attachment is obsolete: true
Created attachment 245587 [details]
zipped testcase

Sigh, getting an online testcase is a bit more difficult than I thought. Here is a zipped testcase.
Attachment #245582 - Attachment is obsolete: true
Attachment #245584 - Attachment is obsolete: true

Updated

11 years ago
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Component: General → DOM
Ever confirmed: true
Keywords: testcase
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → Trunk

Updated

11 years ago
Blocks: 140346
(Reporter)

Comment 8

11 years ago
It is the Quicktime plugin for sure. I uninstalled the one on my pc and tryed again. Now everything works fine... So is it a Quicktime or FF bug?
It's a Mozilla bug, I think.
If bug cannot be reproduced without plugin, then it's plugin's issue.

Please CLOSE as INVALID or WORKSFORME.
Assignee: general → nobody
QA Contact: ian → general
You need to log in before you can comment on or make changes to this bug.