Cookie problem with Tango.

VERIFIED WORKSFORME

Status

()

Core
Networking: Cookies
P3
normal
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: Robert Garcia, Assigned: Stephen P. Morse)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
The tango application server writes a cookie to the user's browser when a
session is started, like many other app servers do. This allow tango to track
the customer through the session, and maintain variables and info for that user.
Tango also uses a UserReferenceArgument passed between pages (through POST or
GET) as a backup. The cookie portion doesn't seem to work which causes Tango to
lose track of the user if the user goes to a part of the site that is not driven
by Tango (raw HTML) and then comes back, or leaves the site momentarily and
returns. The user loses login info, and shopping cart, etc.
(Assignee)

Comment 1

18 years ago
This is working fine for me.  Here's what I did:

1. I went to the URL indicated above and received a login screen.

2. I logged in (giving a phone name and e-mail address of course).

3. I used the cookie viewer and saw that a Tango_UserReference cookie had been 
set.

4. I clicked on a link on the site and saw that the UserReference value was 
passed as a query-string argument in the url.

5. I went to some other site and then returned to the original URL.  No 
query-string argument of course.  And this time I was not asked to log-in, 
indicating that the site indeed recognized me from my cookie.

So I'm closing this out.  If you are still having a problem, then reopen 
and please give a detailed step-by-step scenario of what you did.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 2

18 years ago
I am not seeing any problems with this either on build 2000081008. 
Marking verified worksfome. rgarcia@bighead.net: if we are missing 
something, please review the bug reporting guidelines at http://
www.mozilla.org/quality/bug-writing-guidelines.html and reopen this bug 
with more information about the problem.

Thanks for reporting a bug with mozilla.
Status: RESOLVED → VERIFIED

Updated

13 years ago
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.