if the first font-family listed is not installed, Arial is always shown instead

RESOLVED DUPLICATE of bug 352174

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 352174
11 years ago
11 years ago

People

(Reporter: K Chayka, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061031 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061031 SeaMonkey/1.5a

When the first font listed in the CSS font-family property is not found, Arial is used, regardless of any additional font families listed, or the font set in browser preferences.

I first noticed this on mozilla.org pages (including bugzilla) because I do not have Verdana installed and my browser default is not Arial. Arial is rendered regardless - where is it getting this?


Reproducible: Always

Steps to Reproduce:
1. in a stylesheet, set body {font-family: nothing, serif}

Actual Results:  
The text is rendered using Arial.

Expected Results:  
The text is rendered using the browsers default font for serif (typically TNR)

Fonts render as expected with Win32 nightly builds through Oct 26. There aren't any Win32 trunk builds available from Oct 27-30, so I can't narrow it down any farther.

Will attach a test case. Makes me wonder if this is just one symptom of a larger issue, or if it is an isolated problem.
(Reporter)

Comment 1

11 years ago
Created attachment 244327 [details]
test case showing font-family bug

Comment 2

11 years ago
Welcome to Cairo :)

Sometime between Oct 26 and Oct 31, Seamonkey seems to have switched to the new Cairo rendering backend that's been plaguing us Firefox testers for several months now. There are a number of font issues remaining that have yet to be ironed out, and this is one of them.

*** This bug has been marked as a duplicate of 352174 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.