page displays with blank content area

VERIFIED WONTFIX

Status

()

Core
DOM: Core & HTML
P3
major
VERIFIED WONTFIX
18 years ago
17 years ago

People

(Reporter: buster, Assigned: jst)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

19.69 KB, application/x-zip-compressed
Details
(Reporter)

Description

18 years ago
using debug build 4/14/00
load the above URL
you'll see the background image paint, but no content appears in the main 
content block in the center of the page.

This error appears in the console:
JavaScript Error: ReferenceError: infobox is not defined
URL: http://www.angelfire.com/ms/dhtml/about.html
Line number: 40

maybe this is an IE-specific thing?

Comment 1

18 years ago
It sure does create an awful lot of annoying pop-up windows. I'm reassigning 
this to the DOM guys, because it seems to be JavaScript driven
Assignee: troy → jst
Component: Layout → DOM Level 0
QA Contact: petersen → desale
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M19

Comment 2

18 years ago
Created attachment 8732 [details]
TESTCASE for hidden page bug
(Assignee)

Comment 3

18 years ago
toby, thanks a lot from the great testcase! The original URL doesn't work any
more but the testcase does work. The problem is that the JS relies on the IE
specific JS feature that lets you access elements by using their ID in the JS,
the fix is to make the site use the DOM getElementById() call. I tried this in
the testcase and that makes the content area show up. Marking WONTFIX.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 4

17 years ago
WONTFIX
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.