Minimized TB window doesn't restored by Enter

RESOLVED INVALID

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: Arkady Belousov, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; ru) Opera 9.02
Build Identifier: http://laotzu.acc.umu.se/pub/mozilla.org/thunderbird/releases/1.5.0.7/win32/ru/Thunderbird%20Setup%201.5.0.7.exe

Let compare with MS Freecell game, included into Windows package.

1. When you press Esc there, then its window minimized.
2. Run some window/application; switch from second window to Freecell and minimize it (Esc or Alt-Space/Minimize) - focus returns to second window; exit second application (close its window) - focus returns to Freecell in task bar, but it remains minimized; press Enter - Freecell window will be restored.

With TB:

1. Esc doesn't work to minimize window (missing feature).
2. Run some window/application; switch from second window to TB and minimize it (Alt-Space/Minimize) - focus REMAINS ON MINIMIZED TB WINDOW IN TASKBAR; switch to second window and exit it - focus returns to TB in task bar, but it remains minimized; press Enter - TB window will NOT be restored.

So, I request:

1. Add support for Esc to minimize TB window.
2. Minimizing TB window should switch from TB window to other window.
3. Enter on minimized TB window should restore it.

Reproducible: Always
(Reporter)

Updated

11 years ago
Summary: Minimized TB window doesn't expanded by Enter → Minimized TB window doesn't restored by Enter

Comment 1

11 years ago
1.
Reporter, where did you get the idea that is is how an application should behave under Windows ? Don't you realize that this is a non-standard feature for FreeCell only (it's probably a "boss" key to hide the game quickly when your boss enters the room) ? Can you name another application that behaves like this ? I think a lot of users will be mad when we minimize the app when the Esc is pressed - this is unexpected behavior.

2. I'm not able to confirm this. The focus always switches away from the minimized app.

3. I'm not able to give the taskbar keyboard focus. How do you do that ?
(Reporter)

Comment 2

11 years ago
> Reporter, where did you get the idea that is is how an application should
> behave under Windows ? 

     Because this is convenient. :)

> Don't you realize that this is a non-standard feature
> for FreeCell only (it's probably a "boss" key 

     I sure, this is Boss key. But this is convenient. :)

> 2. I'm not able to confirm this. The focus always switches away from the
> minimized app.

     Right now I write this answer in Opera. I minimize it - focus switched to other window. I open TB window and minimize it - focus remains on minimized TB icon in taskbar.

> 3. I'm not able to give the taskbar keyboard focus. How do you do that ?

     Do you follow steps, as I describe them (with running secondary window)? As secondary window, may be used, for example, Notepad. Let me repeat sequence:

1. Run Notepad.
2. Switch to TB window and minimize it - focus remains on its icon in taskbar.
3. Switch to second window (Notepad) and close it - focus returns to minimized TB icon in taskbar.

Also note: I use Win98 - if you use XP, there may exist some differences in shell behavior.
(Reporter)

Comment 3

11 years ago
In addition: when you click on some program icon in taskbar, then one time its window is selected, other time focus switched to other program. When you click on icon of TB, then after deselection focus from TB icon/window comes to nowhere (to shell/desktop?), no one other program gets focus.
(Reporter)

Comment 4

11 years ago
TB 1.5.0.8: not fixed

Comment 5

10 years ago
regarding items #2 and #3, I don't know about w98 but XP doesn't work like this and what you are asking for is dependent on OS functionality, not Thunderbird. And w98 is no longer supported after TB v2.

No standard windows apps that I know of minimize when hitting <esc>.  If you want to ask for that please file a new bug - but I can't imagine it ever being provided.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

10 years ago
(In reply to comment #5)
> regarding items #2 and #3, I don't know about w98 but XP doesn't work like this
> and what you are asking for is dependent on OS functionality, not Thunderbird.

     You wrong, because this depends on events handler loop in application. Enter on minimized Notepad window restores it; Enter on minimized console window restored it; Enter on minimized Opera window restored it. Only TB behaves exclusively.

PS: Right now I check TB 2.0.0.14 - focus does switched from it when I minimize it ([2] request fixed - deliberately or unintentionally), but restoring TB window ([3] request) doesn't work, as previously.

> And w98 is no longer supported after TB v2.

     Does this mean, that I should right now forget not only Firefox, but also TB, and search alternative solutions?

> No standard windows apps that I know of minimize when hitting <esc>.  If you

     What you count as "standard"? Freecell is part of distributive. Also, <Esc> as minimize supported by some (3rd party) apps. But, I not understand, what confuse you and why you require that any ("standard" or not) application should or should not implement this nice feature before consider it to include into TB.

> want to ask for that please file a new bug - 

     Why I should if TB will not work for me anymore in next versions?

> but I can't imagine it ever being
> provided.

     Do you know word "security" and "privacy"? What happen if I read some very personal post and someone comes at my back? "Boss" key add additional privacy protection not only against Boss, but against any curious person.

Comment 7

10 years ago
(In reply to comment #6)
> (In reply to comment #5)
> 
> > And w98 is no longer supported after TB v2.
> 
>      Does this mean, that I should right now forget not only Firefox, but also
> TB, and search alternative solutions?

Firefox 3 does not support w98, so if your plan is to stay on w98 ...
(Reporter)

Comment 8

10 years ago
[offtopic]

> Firefox 3 does not support w98, 

     I don't know. Firefox is free(dom), but it was unstable, fat and not enough features, so I long ago drop it in favor of other browser, which non-free(dom), but it (works) much better. TB also was and is unstable (last four versions it often crashed; it two years have broken newsgroup database on my machine; there was and is many other problems), fat and not enough features, but I anyway was try to trust it. If it will not support my platform, this will enough reason to drop it too.

> so if your plan is to stay on w98 ...

     Yes, I do.
You need to log in before you can comment on or make changes to this bug.