site uses a security protocol which is not enabled

RESOLVED INCOMPLETE

Status

()

Core
Security: PSM
--
major
RESOLVED INCOMPLETE
12 years ago
4 years ago

People

(Reporter: Lindsay Abel, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

EMail received:
>Tried to go to the hospital web site using the new Firefox 2.0 and was
>not able to connect.  The error message was, in essence, that Firefox
>was unable to securely connect to the site as the "site uses a security
>protocol which is not enabled."  This is a problem which was not present
>in the earlier versions of Firefox.

Response from Web host:

I've seen the same thing in Firefox 2.0. It doesn't occur initially, but 
develops after FF2 has been running awhile. I cured it by tweaking one of 
the "hidden" prefs using about:config:

security.enable_ssl2 = true

I suspect it's a bug in Firefox, or at least a mistake in the default 
preference settings. FF2 is full of bugs.

Reproducible: Always

Steps to Reproduce:
1. Go to Web site
2.
3.

Actual Results:  
"site uses a security protocol which is not enabled."

Expected Results:  
Opened the Web site.

Comment 1

12 years ago
Umm.. SSL2 is disabled because it is the one with security bugs. Inform the admin of the site to update to SSL3. Resolve this as invalid.
Well, while enabling SSL2 is no fix, perhaps we could look at why it's only a sometimes thing (I loaded all but two images successfully before I started getting SSL2 warnings) before we start saying it's not us, it's them?
Assignee: nobody → dveditz
Component: Error Console → Security
Product: Firefox → Core
QA Contact: javascript.console → toolkit
Version: unspecified → 1.8 Branch
Assignee: dveditz → kengert
Component: Security → Security: PSM
QA Contact: toolkit

Comment 3

12 years ago
No problems observed with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20061102 SeaMonkey/1.5a. The home page and 2nd link on the homepage are https, but the others I tried are all http. The page info says the security used is AES-256 256-bit encryption.

Comment 4

12 years ago
I can not reproduce.

Do you see this bug on Apple, on Windows, or both?

Do you really see it with https://www.lakewoodranchmedicalcenter.com/ - or rather with a link you click on that site?

I saw it with a Mac trunk build a couple of days old, over a dialup connection, just loading the site's home page, and haven't been able to reproduce with a Windows Fx 2 build on a decent connection, no matter how much I poke around the site.

Assuming I can reproduce at will with a crappy connection, are there logging instructions somewhere I can use to see what's happening when it decides to switch?
QA Contact: psm

Comment 6

8 years ago
Mass change owner of unconfirmed "Core:Security UI/PSM/SMime" bugs to nobody.
Search for kaie-20100607-unconfirmed-nobody
Assignee: kaie → nobody
Is this still an issue ?
Flags: needinfo?(lindsay.abel)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
Flags: needinfo?(lindsay.abel)
You need to log in before you can comment on or make changes to this bug.