Closed Bug 359212 Opened 16 years ago Closed 14 years ago

Autofill doesn't work on bookmarked pages opened in the new tab (from Personal Toolbar Folder)

Categories

(Toolkit :: Form Manager, defect)

x86
All
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 424646

People

(Reporter: mszpak, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060913 Fedora/1.5.0.7-1.fc5 Firefox/1.5.0.7 pango-text
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060913 Fedora/1.5.0.7-1.fc5 Firefox/1.5.0.7 pango-text

On bookmarked pages stored in Personal Toolbar Folder, opened in *new* tab (CTRL-click) autofill doesn't work in default edit. It's required to change focus and return to that edit (e.g. TAB, SHIFT-TAB) to get autofill works.

This happens with every site on which focus is by default on some edit, like: https://www.google.com/accounts/ServiceLogin?service=mail

Reproducible: Always

Steps to Reproduce:
1. Add https://www.google.com/accounts/ServiceLogin?service=mail to your Personal Toolbar Folder.
2. CTRL-click on it.
3. Try to get autofill by starting typing or pressing down arrow.

Note: if you haven't uses some page earlier, you have to type something and try to login (even with error), to give Firefox change to display hint next time.

Actual Results:  
Autofill doesn't work.

Expected Results:  
Autofill try to help me (when I'm typing or pressing down arrow).

Confirmed in 1.5.0.7 and 2.0 under Linux and Windows. Probably available also in 1.x (and earlier).
Without problems when openned in current tab.
This looks like a duplicate of Bug 268145 or Bug 267703 only this one regressed later (after 1-1-2005).
I think this bug may be the the same as the other two, but the description on other two points to a possibly more specific problem. This one is actually very general, and I can confirm it affects 1.5.0.x and 2.0.0.x on both Linux and Windows.

It's actually even easier to see this bug. It affects autofill in forms in any newly opened tab (as in "Open in New Tab"). Go to a site like www.google.com and enter something like "foo" in the form (just so you have form entry history). Enter www.google.com in the address bar, and hit Alt+Enter to open it in a new tab. The form will not offer to fill any previous entries. This can also be triggered by using a bookmark or a link to generate the new tab.

There are two workarounds I'm aware of. First, open a new tab (Ctrl+T), then enter the site via address bar or bookmark. Or, switch to a different tab and back.

I'd like to have a go at fixing the code. Could someone point me to the part of the code where tabs are generated for Firefox? It seems browser/base/content and browser/components are likely spots.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1a1pre) Gecko/2008062003 Minefield/3.1a1pre

Confirmed for FF3 and 3.1pre. I followed Dan's instructions in comment #2 as well as the the original STR and it did not remember the autofill in both cases. 

This bug is the same as bug 424646 which is confirmed. I will dupe this one and cite it in that bug because this has good instructions.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424646
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.