Page flickers on hyperlink mouseover in non-paragraph text below centered text within a span

VERIFIED WORKSFORME

Status

Core Graveyard
GFX
P3
trivial
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Steuard Jensen, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win95; U)
BuildID:    2000022820

In very specific circumstances, it seems that moving the mouse onto or off of a 
hyperlink causes a significant flicker of the screen, which I believe is due to 
a full redraw of the page.  In particular, the hyperlink must be within a span 
and underneath centered text which is also in the same span.  Moreover, the 
hyperlink must be within a block of text that is NOT marked as paragraph (with 
paragraph tags).
If any of these conditions do not hold, then the flicker seems to be absent.  (I 
haven't checked what happens in _similar_ situations, e.g. hyperlinks in lists 
rather than in paragraphs, or other initial positioning commands than CENTER.)


Reproducible: Always
Steps to Reproduce:
1. Open Mozilla
2. Go to the URL http://home.uchicago.edu/~sbjensen/Flicker.html
3. Move the mouse onto and off of the hyperlink in the FIRST paragraph (doing 
this quickly tends to produce the most obvious results).

Actual Results:  The text on the page flickers substantially.

Expected Results:  No change in the appearance of the page should occur.  (In 
other words, exactly what happens when the mouse is moved over the hyperlink in 
the second paragraph on this page.)

It is possible that users with more RAM on their motherboards or video cards 
(or perhaps just more recent video cards) will not be able to see this effect, 
as faster graphics could well make the flicker less noticable.  My system has a 
mere 24MB RAM and 2MB video RAM (I think), with a four year old Number 9 video 
card and an AMD-K6-350 processor.

The following fragment is also available at the URL below.  It is just a 
stripped down version of the sample URL given above.  Note that because there is 
less displayed material here, the flicker is considerably less noticable.

http://home.uchicago.edu/~sbjensen/Flicker1.html

<HTML><BODY>
<SPAN>

<CENTER>Initial Centered Text</CENTER>

Moving the mouse onto and off of <A href="pk.html">a hyperlink</A>
inside a SPAN underneath CENTERed text causes a full page redraw.

</SPAN>
</BODY></HTML>

Comment 1

18 years ago
Reproduced with M14 on PC/Linux.
Does not occur any more on current build 2000-04-14-09-M16.
Marking WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 2

18 years ago
This problem is fixed in the April 26th build.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.