Can't save current document source with arbitrary extension

RESOLVED FIXED

Status

Camino Graveyard
Downloading
--
minor
RESOLVED FIXED
12 years ago
7 years ago

People

(Reporter: Sebastian Winkler, Assigned: Smokey Ardisson (offline for a while; not following bugs - do not email))

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061102 Camino/1.1a1+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061102 Camino/1.1a1+

The Save As… dialog does not permit override of the default extension to be used for the saved file. Instead it toggles the "Hide Extension" option.
For the "HTML Complete" and "Plain Text" options this may be considered a feature.
For the "HTML Source" option it actually poses a hinderance to naming the source file appropriately.
The situation is aggravated by Camino insisting on the default .html extension, regardless of the remote files original extension. Again, I suppose that in certain situations offering to append the html extension can be of advantage. But imposing it never is.

Reproducible: Always

Comment 1

12 years ago
Confirming. Appending the '.html' extension to some pages (for example, the PHP files served up by Wikipedia, or the CGI files served up here at Bugzilla) is part of a different bug (bug 181029), but the inability to change the hidden extension in any way is something we ought to fix.

cl
Status: UNCONFIRMED → NEW
Ever confirmed: true
I didn't understand this bug at first, so a second explanation:

If you have "Hide extension" turned off and delete the HTML extension (or replace it, or attempt to append a different extension), we automatically switch "Hide extension" back on (which is really evil) and re-append .html.
Target Milestone: --- → Camino1.2

Comment 3

12 years ago
To be technical, *we* don't; Cocoa does.

Comment 4

11 years ago
You must be asking Cocoa to do it somewhere, because you get this dialog when you save the current page, but not when you download the same file as a link... there the dialog lets you choose between html and wav.
Mass un-setting milestone per 1.6 roadmap.

Filter on RemoveRedonkulousBuglist to remove bugspam.

Developers: if you have a patch in hand for one of these bugs, you may pull the bug back to 1.6 *at that point*.
Target Milestone: Camino1.6 → ---
This is because we set setRequiredFileType in the Save dialogues in order to get the correct filename-selection semantics (among other things), but also because we have to force an extension on view-source or it fails to save (bug 169789).
Pending the outcome of review, the patch in bug 583818 should fix this.
Assignee: nobody → alqahira
Depends on: 583818
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.