bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

MarketLinx website may not work in Firefox




12 years ago
7 years ago


(Reporter: Pierre Fortin, Unassigned)


Firefox Tracking Flags

(Not tracked)



(1 attachment)



12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

I'm a Realtor and have an issue with one Edit button on a Multiple Listing site (no public access).

Strangely, the only difference I can find between all the other buttons that work and the Edit button which only changes its label from "Edit" to "Working ..." is that the value="" field has blanks around the text:

    value="    Edit    "

whereas the others don't.  Also, I can't seem to find where the button's text get changed from "Edit" to "Working ..." in either the frame source or the main page...  to be sure, I started wireshark to monitor the link when I clicked on this Edit button; but saw no traffic at all, so the change to "Working ..." has got to be local...  

I've asked the website admin to remove the spaces; but am not expecting a positive response to this request from an non-IE user...  :^(

Reproducible: Always

Steps to Reproduce:
1.  get to page which contains frame source (attached)
2.  Click Edit button
3.  button changes to "Working ..."; but does not request edit mode from server

I have several addons and tried to use the "Edit HTML" feature...  sadly, this forces a page reload which causes the server to revert to a page from which I must click through to get back to this one -- and each clickthrough causes a reload, so there is NO way for me to get to the point where I can edit out the blanks locally...

Comment 1

12 years ago
Created attachment 244571 [details]
frame source

I can provide the full page source (~160K if necessary)...

Comment 2

12 years ago
> I have several addons and tried to use the "Edit HTML" feature...

For working around this problem, you want something that lets you edit a live DOM, not HTML.  DOM Inspector can do this but there might be better extensions for this kind of thing.

Comment 3

12 years ago
A small page demonstrating what differs between IE and Firefox would be ideal.  But if you can't do that, you can attach the whole page and hope someone else takes the time to figure out why it doesn't work in Firefox.

Comment 4

12 years ago
Actually, the site masters categorically deny support for anything but IE6 (not even IE7), so the page doesn't change for IE v. Fx

I repeated the sequence while running wireshark and saved the TCP streams from the  login.  Strangely, I can't find a single occurrence of the string "Working" that replaces "Edit" on the first button.

Gonna give Fx3 a try for grins...  more later.


10 years ago
Product: Firefox → Toolkit
So, was this still reproducible with Firefox 3?

Comment 6

10 years ago
No way to tell now... the moronic developers at MarketLinx (www.marketlinx.com) [or the idiotic webmasters at our MLS] have blocked all but IE browsers in their latest version. :(  It'll be interesting to see if MarketLinx responds to my query.
Close this bug.
Ok. Feel free to reopen if there's a way to test this!

Moving to FF:General, because I think it's more likely to be some other issue anyway (ie, not forms).
Last Resolved: 10 years ago
Component: Form Manager → General
Product: Toolkit → Firefox
QA Contact: form.manager → general
Resolution: --- → INCOMPLETE
Summary: form input type button value: spaces in value=" foo " apparently fail → MarketLinx website may not work in Firefox


7 years ago
You need to log in before you can comment on or make changes to this bug.