CLICKING LINKS (Forum Links, even JPG Image Files) makes Page Jump to Top

RESOLVED DUPLICATE of bug 351491

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 351491
12 years ago
12 years ago

People

(Reporter: Joe Wood, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

As I said, when I click a link, it doesn't open and instead makes the page jump back to the top, so I scroll back down and usually it'll open when I click it again.

Seems like it doesn't happen again after the first jump, but instead usually only when I enter some site first the time.

Caret Browsing is not turned on.

The only Extensions I have are Robo Form, G Translate, and Ad Block

I tried renaming the LocalStore.rdf, but that didn't help at all.

I'm on WinXP Home. Have had FFox for two years, this problem is with the new FF 2 I recently updated to.

Reproducible: Sometimes




Using default Theme
On which URL?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> On which URL?
> 

Here's the one where it happens the most for me. You'll need to register first I think. http://forums.taunton.com/tp-breaktime/messages?msg=39386.1945&redirCnt=2

if you can get in to the forums, the thread links on the left side of the page are where it happens often, but then, once in a thread it'll happen when I click other links or even image files.
 
Does it also happen with disabled extensions (or in Firefox's safe-mode) and after you have pressed F7 (caret browsing)?
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> Does it also happen with disabled extensions (or in Firefox's safe-mode) and
> after you have pressed F7 (caret browsing)?
> 

Well, I haven't tried disabling the extensions. Could any of those extensions I mentioned cause this problem?

I'll go do a Search for FFox Safe Mode, I haven't heard about it. 

When would I use F7? Just as I get to the site?
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> (In reply to comment #3)
> > Does it also happen with disabled extensions (or in Firefox's safe-mode) and
> > after you have pressed F7 (caret browsing)?
> > 
> 
> Well, I haven't tried disabling the extensions. Could any of those extensions I
> mentioned cause this problem?
> 
> I'll go do a Search for FFox Safe Mode, I haven't heard about it. 

When would I use F7? Just as I get to the site?

EDIT: OK< I just tried F7, and turned the caret browsing on, but that didn't help.
> 

(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > Does it also happen with disabled extensions (or in Firefox's safe-mode) and
> > > after you have pressed F7 (caret browsing)?
> > > 
> > 
> > Well, I haven't tried disabling the extensions. Could any of those extensions I
> > mentioned cause this problem?

I'm hoping this subject isn't dead. If anyone needs any more info, or has any suggestions for me ..
> > 
> > I'll go do a Search for FFox Safe Mode, I haven't heard about it. 
> 
> When would I use F7? Just as I get to the site?
> 
> EDIT: OK< I just tried F7, and turned the caret browsing on, but that didn't
> help.
> > 
> 

(Reporter)

Comment 7

12 years ago
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > (In reply to comment #3)
> > > > Does it also happen with disabled extensions (or in Firefox's safe-mode) and
> > > > after you have pressed F7 (caret browsing)?
> > > > 
> > > 
> > > Well, I haven't tried disabling the extensions. Could any of those extensions I


PROBLEM SOLVED SO FAR! Tools>Options>Advanced and Unchecked those options under Accessibility.

Is anyone still reading this Bug report??
> > > mentioned cause this problem?
> 
> I'm hoping this subject isn't dead. If anyone needs any more info, or has any
> suggestions for me ..
> > > 
> > > I'll go do a Search for FFox Safe Mode, I haven't heard about it. 
> > 
> > When would I use F7? Just as I get to the site?
> > 
> > EDIT: OK< I just tried F7, and turned the caret browsing on, but that didn't
> > help.
> > > 
> > 
> 

Comment 8

12 years ago
user_pref("accessibility.browsewithcaret", true); This mean tha by pressing F7 the problem is solved. Is Not A Bug.
(Reporter)

Comment 9

12 years ago
No, I didn't solve it with F7, instead I went to Tools>Options>Advanced and Unchecked those options under Accessibility.

This also cleared up my Back Button issue which was going back to the top of the last page I was on instead of the location I was on that page.
I used to see this bug too (on BonEcho 2.0 for Linux) but at this precise moment I cannot reproduce it at will.

I am currently on "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061114 BonEcho/2.0" - Build ID: 2006111404 - but I'll soon upgrade to the next nightly on the 2.0 branch.

I think bug 360412 is a dupe of this one, or that both are dupes of bug 358409, but I don't have the privilege to resolve them.

Comment 11

12 years ago
Greetings. I've been getting this problem happening quite often since I upgraded from Firefox 1.0.5.7 to 2.0. It's a generic Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0. I have IEView and Modify Headers Add-ons/Extensions installed. Otherwise, all configuration settings are default.

Like everyone else, there's no single URL I can provide to reproduce the bug. This will no doubt make it frustrating for everyone!

On my system, the bug is exhibited like this:
1. A long page is loaded (so the user can scroll down).
2. The user scrolls down and clicks on a link (any link).
3. The browser immediately scrolls back to the top.
4. The user scrolls back down to the link they just clicked a second time.
5. The link (text) is surrounded by a dotted rectangular box, similar to that which is displayed when a user right-clicks (Windows) on a text link. I think this means that at some level, the original click appears to have "made it" to the browser.
6. The user clicks on the link a second time, and it goes through.

- I've seen this happen a lot on HTML forms. Maybe not so much on "regular" pages. Perhaps someone else on this bug can confirm or deny the relationship here.
- The second click *always* works.
- This never ever ever happened before Firefox 2.0
This was a branch regression from the patch for bug 144000. It will hopefully be fixed in Firefox 2.0.0.1.

*** This bug has been marked as a duplicate of 351491 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.