Closed Bug 359439 Opened 13 years ago Closed 13 years ago

input form field's cursor/caret appears to the left of actual input field, "on top of" the text to the left.

Categories

(Firefox :: General, defect, major)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 167801

People

(Reporter: kalle, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20060601 Firefox/2.0 (Ubuntu-edgy)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20060601 Firefox/2.0 (Ubuntu-edgy)

For some odd reason, the caret appears to the left of the actual input field in the to-be-attached test case. This appeared online at a web site and was confirmed by myself and one other user, and it appeared when I "saved page as" to my home dir and opened the html file locally. The problem appears when the CSS for input is set to "display: block;", and the CSS for table is set to "width: 100%; text-align: center;" .. removing either of the three CSS declarations prevents the bug from appearing.

Reproducible: Always

Steps to Reproduce:
1. Open the to-be-attached html file in Firefox. 
2. Click to focus the input field.

Actual Results:  
The caret/cursor appears to the left of the input field.


Expected Results:  
The caret/cursor should appear at the beginning of the input field.

The bug appears sporadically. To force it to appear, click URL field, hit ENTER, then click input field again (do not use F5/refresh).
Confirmed by two other users. One on FF 2.0 (Ubuntu Edgy platform default). More interestingly, user #2 reports the bug on Firefox 1.5.0.x, OS X 10.4.
This looks like a dupe of 167801 to me (without the overlapping div to hide the caret being in the wrong spot.)

*** This bug has been marked as a duplicate of 167801 ***
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.