Closed Bug 359523 Opened 13 years ago Closed 12 years ago

Ok button greyed out if downloading files with a .zip extension ( con't from 284579)

Categories

(Toolkit :: Downloads API, defect, minor)

1.8 Branch
x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 264492

People

(Reporter: fixer, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Using the current release of Firefox (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0) on Windows XP SP2.

This is very similar to BID 284579, but a key difference is when I click on the zip file to download the focus DOES shift to the download dialog box, but the ok button remains greyed out.  If I click on the ok button it will light up, then if I click it again it will download the file.

This only happens with .zip files and does not appear to depend on the website being downloaded from.  This behavior did not appear in previous FF versions.  I have not tested it on other platforms so I cannot confirm whether or not it happens on anything other than XP.  I have seen it on two different XP SP2 systems with the latest FF build.

Reproducible: Always

Steps to Reproduce:
1. Go to URL that has a zip file to download
2. Click on hyperlink to download the zip file
3. Focus will shift to the confirmation dialog but the ok button will be grey.

Actual Results:  
the ok button remains greyed out.  If I click on the ok button it will light up, then if I click it again it will download the file.

Expected Results:  
The ok button should be lit up when the dialog box first appears.

Using the default theme in both instances.  Plug-ins don't appear to be a factor.
Dupe of/related to bug 264492?
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 2.0 Branch
Duplicate of bug: 264492
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.