Closed Bug 359530 Opened 13 years ago Closed 13 years ago

checkbox use master password: wrong behaviour when deleting password

Categories

(Calendar :: General, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: damian.publicemail, Assigned: mattwillis)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061103 Calendar/0.4a1

to reset master password you have to confirm current password, but when you use checkbox you don't get dialog to do it

Reproducible: Always

Steps to Reproduce:
1. set master password in preferences->advanced->passwords (set checkbox and fill password)
2. uncheck "use master password"
3. close preference dialog via OK button
4. open again preferences
Actual Results:  
checkbox is selected

Expected Results:  
checkbox should not be selected
when you try to uncheck checkbox you should be asked for current password

you can reset password via "Change master password": confirm old and leave new one empty
Confirmed.
I'm taking a look at this to see what's up.
Assignee: nobody → lilmatt
Caused by this typo in advanced.js:

     _removeMasterPassword: function advRemoveMasterPassword() {
-        if (this._secmodDB.isFIPSEnabled) {
+        if (this._secModDB.isFIPSEnabled) {
             var bundle = document.getElementById("bundlePreferences");

Fix checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061105 Calendar/0.4a1

Sorry, I'm afraid it's still there.
I tried clicking OK and the reopening the Preferences-Dialog and also did the same with restarting Sunbird.
> Sorry, I'm afraid it's still there.
Yeah, this is why i'm waiting for next build to be sure before I reopen this issue
Problem is still valid with 20061105 build. Error Message:

Error: this._secModDB has no properties
Source File: chrome://calendar/content/preferences/advanced.js
Line: 149

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Typo fix checked in.

Thanks to jminta for helping me find the thing.

-> FIXED
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061106 Calendar/0.4a1
Whiteboard: [litmus testcase wanted]
Whiteboard: [litmus testcase wanted]
You need to log in before you can comment on or make changes to this bug.