nsXFormsInputAccessible::GetExtState compiler warning in nsXFormsFormControlsAccessible.cpp

RESOLVED DUPLICATE of bug 354728

Status

Core Graveyard
XForms
--
minor
RESOLVED DUPLICATE of bug 354728
12 years ago
2 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

12 years ago
When doing a trunk compile, I'm getting the following compiler error:

c:\mozbuild\mozilla\accessible\src\xforms\nsxformsformcontrolsaccessible.cpp(191) : warning C4715: 'nsXFormsInputAccessible::GetExtState' : not all control paths return a value

Patch forthcoming.
(Reporter)

Comment 1

12 years ago
Created attachment 244731 [details] [diff] [review]
Simple patch

Adds missing return NS_OK
Attachment #244731 - Flags: review?(aaronleventhal)

Comment 2

12 years ago
This will be fixed by bug 354728. I guess we should mark this bug as dupe.
(Reporter)

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 354728 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

12 years ago
Attachment #244731 - Attachment is obsolete: true
Attachment #244731 - Flags: review?(aaronleventhal)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.