Content fontsize affects chrome fontsize when latter set as 'large'

NEW
Unassigned

Status

()

12 years ago
8 years ago

People

(Reporter: ehume, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061104 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061104 Minefield/3.0a1

HiVisGnome Big and Jumbo use font-size = large and x-large to render text more visible to users with visual problems. One would expect these fontsizes to be affected by the system settings of menu and Message Box, and they are.

However, the size of the text in chrome (toolbars, tree, etc.) are also affected by the default fontsize setting (Tools > Options > Content > Default Font). This means that when a user sets his default setting to be large, then the font size of the theme is larger than it should be, potentially making the theme unusable.


Reproducible: Always

Steps to Reproduce:
1. Install HiVisGnome Big.
2. Restart browser. Observe text size (initial default size is 16).
3. Set default text size to another value (e.g. - 24).
4. Restart browser and observe change in text size.

Actual Results:  
Font size in chrome is changed.

Expected Results:  
Font size in chrome should not be changed.

For an additional treat, try this:

Open Bookmarks > Manage Bookmarks. Observe the textsize.
Close Manage Bookmarks. Change the default font size.
Open Manage Bookmarks. Observe the textsize. It is now different.

Comment 1

12 years ago
It seems to happen in "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061113 Minefield/3.0a1".  CCing Beltzner, and moving to "Toolbars" component for further investigation.
Component: General → Toolbars

Comment 2

12 years ago
The problem seems to occur before, and it doesn't seem to occur anymore with a reinstallation of the theme, or in a new profile?

Comment 3

12 years ago
But now the problem seems to be occuring in the Bookmarks Manager.  Forgot to check before.

Sorry for the mass of comments I generated. ;)

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Toolbars → General
You need to log in before you can comment on or make changes to this bug.