Disabled options display and/or are selectable

VERIFIED DUPLICATE of bug 1134

Status

()

P3
normal
VERIFIED DUPLICATE of bug 1134
20 years ago
20 years ago

People

(Reporter: cpratt, Assigned: kmcclusk)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Using the following HTML snippet, the menu displayed should do something to
prevent the 'Keemun' and 'Yunnan' options from being 'successful'. According to
the HTML 4.0 DTD, it's up to the user agent to render these things; it suggests
that we 'gray out' the disabled menu items. Currently, those two menu items look
the same as the others, and they are selectable. Frankly, I'm not sure what we
should do here, but I did want to call attention to this.

form action="mailto:Kligor.T@gee.whiz.com">
	<select>
		<option>Assam
		<option>Darjeeling
		<option>Dooars
		<option disabled>Keemun
		<option>Nilgiri
		<option disabled>Yunnan
	</select>
<input type=submit>
</form>

Updated

20 years ago
Assignee: karnaze → kmcclusk
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

20 years ago
Target Milestone: M5
(Assignee)

Updated

20 years ago
Target Milestone: M5 → M7
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

20 years ago
*** This bug has been marked as a duplicate of 1134 ***
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.