error message at startup: Failed to execute child process "/usr/local/libexec/gconfd-2" (Invalid argument)

RESOLVED FIXED

Status

()

Toolkit
Startup and Profile System
--
minor
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: Lena, Unassigned)

Tracking

1.8 Branch
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8.1) Gecko/20061104 Firefox/2.0
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8.1) Gecko/20061104 Firefox/2.0

On FreeBSD 6.1 (with Russian locale) after Firefox upgrade from 1.5.0.7 to 2.0
at startup on the console where I issue "startx&" an error message
(partly in Russian):

Ошибка системы GConf: Сбой при запуске сервера конфигурации: Сбой при выполнении
 процесса-потомка "/usr/local/libexec/gconfd-2" (Invalid argument)

By googling I found (on a Chinese site http://c32.no-ip.com/diary/?1103 )
English equivalent of this error message:

GConf Error: Failed to launch configuration server: Failed to execute child
process "/usr/X11R6/libexec/gconfd-2" (Invalid argument)

"ps axww" shows a dead process ("zombie") instead of customary "gconfd":

97790  v5  Z      0:00,03 <defunct>

Firefox seems to work OK. Sorry, I don't know what gconfd should be doing
and where to take additional debugging info - please give me instructions
how to extract it. :)

Reproducible: Always

Steps to Reproduce:
I just issue "startx&" command on a virtual console (not in xterm)
which starts Firefox (by "exec firefox" in ~/.xinitrc)
and look at the console.
Actual Results:  
The error message quoted in Details.

Expected Results:  
There wasn't such error message before the upgrade from 1.5.0.7 to 2.0.
Also, "ps" showed gconfd process instead of a zombie now.

Defaut theme, Firefox non-russified (English), but
Russian locale while starting Firefox.
All dependencies freshly upgraded.
Forced reinstall of gconf2 didn't help.

about:buildconfig

Build platform
target
i386-unknown-freebsd6.1

Build tools
Compiler 	Version 	Compiler flags
cc 	gcc version 3.4.4 [FreeBSD] 20050518 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -O2 -fno-strict-aliasing -pipe -march=pentium3 -O2 -pipe
c++ 	gcc version 3.4.4 [FreeBSD] 20050518 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -O2 -fno-strict-aliasing -pipe -march=pentium3 -O2 -fshort-wchar -pipe -I/usr/X11R6/include -I/usr/X11R6/include -I/usr/X11R6/include

Configure arguments
--prefix=/usr/ports/www/firefox/work/fake --enable-application=browser --enable-system-cairo --enable-official-branding --enable-canvas --with-system-nss --enable-svg --enable-svg-renderer=cairo --enable-crypto --disable-tests --enable-default-toolkit=gtk2 --enable-xft --with-pthreads --x-includes=/usr/X11R6/include --x-libraries=/usr/X11R6/lib --enable-extensions=default --enable-image-decoders=default --enable-necko-protocols=default --with-system-jpeg=/usr/local --with-system-zlib=/usr --with-system-png=/usr/local --with-gssapi=/usr --with-system-nspr --disable-auto-deps --enable-chrome-format=jar --disable-cpp-exceptions --disable-cpp-rtti --disable-glibtest --disable-gtktest --disable-freetypetest --enable-double-buffer --enable-mathml --disable-installer --disable-md --disable-pedantic --disable-bidi --disable-xterm-updates --enable-xinerama --disable-debug --enable-optimize= --enable-strip --disable-logging
(Reporter)

Updated

11 years ago
Summary: error message at startup: Failed to execute child process "/usr/X11R6/libexec/gconfd-2" (Invalid argument) → error message at startup: Failed to execute child process "/usr/local/libexec/gconfd-2" (Invalid argument)
Version: unspecified → 2.0 Branch
(Reporter)

Comment 1

11 years ago
As I wrote here on November 5, updating all dependencies didn't help.
Yesterday I again updated dependencies (there were some updates since I
reported this bug), today no error message at firefox startup, and the
gconfd process again appeared instead of a zombie:

top:
  PID USERNAME  THR PRI NICE   SIZE    RES STATE    TIME   WCPU COMMAND
  631 lena        1  96    0  4312K  1440K select   0:00  0.00% gconfd-2

ps axww:
  PID  TT  STAT      TIME COMMAND
  631  v9  S      0:00,25 /usr/local/libexec/gconfd-2 14

Also, I noticed that gconfd isn't among firefox dependencies.
Why it starts at firefox startup is an enigma for me. :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.