If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Contextual Tab Navigation

VERIFIED DUPLICATE of bug 342831

Status

Camino Graveyard
Tabbed Browsing
--
enhancement
VERIFIED DUPLICATE of bug 342831
11 years ago
11 years ago

People

(Reporter: survivor, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061029 Camino/1.1a1+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061029 Camino/1.1a1+

Users should be able to hit a key combo to do a contextual tab search

Sort of like Quicksilver or other application launchers, the tab bar would then be selected and you could type the first few letters of the tab you want to select.

So if I currently have the following tabs open it would function as follows: [Gmail - Inbox (3)] [Enter A Bug] [Google]

I could hit option+tab to enable, then if I typed E it would bold the Enter A Bug tab and select it if I hit enter. If I instead paused a few seconds and then typed Gm it would select Gmail tab and then open it if I hit enter, etc.

At the very least, option+tab should function like it does in Opera, where it brings up a list of all the tabs in the center of the screen and lets you tab between them like you would applications with apple+tab.

Reproducible: Always

Comment 1

11 years ago

*** This bug has been marked as a duplicate of 342831 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
See also bug 197720 and bug 312007.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.