Charset/encoding problem in .ics files from Exchange server

RESOLVED DUPLICATE of bug 357172

Status

RESOLVED DUPLICATE of bug 357172
13 years ago
12 years ago

People

(Reporter: magnus, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Version 0.4a1, nightly build 2006110607

When I get invitations from our Exchange server including non-ASCII characters, they don't display properly. For instance, I get "berätta" instead of "berätta" (I hope the bugzilla doesn't corrupt these examples)
This looks like UTF-8/Latin-1 have been mixed up somehow. "berätta" is how the UTF-8 encoding of "berätta" typically look, when you view it as if it were an 8859-1 encoding.

However, the message itself appears to have been sent in 8859-1, according to the headers. I'll attach an example message to this bug report.

Reproducible: Always

Steps to Reproduce:
Have a friend send you an invitation on an Exchange server, using international characters (like the swedish "åäö") in the description or title.



I thought it might be related to bug 167800, even though it didn't really match. However, that problem seemed to have been solved, so I downloaded the latest nightly build, but the same problem was there. There might still be some kind of relation, somehow (?).
(Reporter)

Comment 1

13 years ago
Sorry, the previous description was not really correct. The message from the Exchange server consists of three parts -- two of them use 8859-1. The third part, however, is the attached .ics file, which I presume Lightning is using. That is encoded in UTF-8. However, this encoding is not expressed in the headers for the attachment, and Lightning appearantly defaults to believing it is 8859-1. 

Anyway, I'll attach a demo email. The names have been changed to protect the innocent.
(Reporter)

Comment 2

13 years ago
Created attachment 244815 [details]
Demo email. The names have been changed to protect the innocent.
Maybe this is related to bug 357172.

Comment 4

12 years ago
This is a duplicate of 357172. Since 357172 is a little older and has a screen shot as well as an email, I'm going to dupe this one against that one.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 357172
You need to log in before you can comment on or make changes to this bug.