TD with "display: block" not displayed at all

VERIFIED FIXED

Status

()

Core
Layout: Tables
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Nicholas O. Radov, Assigned: karnaze (gone))

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; Windows NT 5.0; en-US; m14)
BuildID:    2000030314

A JavaScript function intended to hide and display various elements by setting
the CSS display property stops working after the second time it is called.

Reproducible: Always
Steps to Reproduce:
1. Load the referenced URL.
2. Click on the blue triangle. The title next to it will be hidden and some
previously hidden data below it will appear.
3. Click on the blue triangle again.
4. Click on the blue triangle again.


Actual Results:  After step 3 the DIV element is correctly hidden but the TD
element is not displayed. After step 4 nothing happens at all.

Expected Results:  Every time the user clicks on the IMG it should hide or
display the contents of the "physician-data-section-header-text" TD element and
the "physician-data" DIV element.

To see how it is really supposed to work try the page with MS Internet Explorer 5.0.

Comment 1

18 years ago
There are two bugs here.  One is that after step 4 nothing happens at all--the
onClick handler jsut disappears. I filed that as bug 36014.

The other problem is that a table cell with display: block doesn't show up at
all.  So I suppose this should go to HTML Tables or Style System or Layout; I'll
try Karnaze first.

Workaround for the two problems in this specific case: Put the onClick handler
on the IMG instead of the TD, and put the header-text in a DIV like so:
     <TD nowrap><DIV id="physician-data-section-header-text">
      Ordered ROUTINE by DR PCP, MD</DIV>
     </TD>
Assignee: rogerl → karnaze
Status: UNCONFIRMED → NEW
Component: Javascript Engine → HTMLTables
Ever confirmed: true
Keywords: testcase
QA Contact: pschwartau → chrisd
Summary: JavaScript only sets display style once → TD with "display: block" not displayed at all

Comment 2

18 years ago
Created attachment 7639 [details]
testcase

Comment 3

18 years ago
Side question: In the testcase, the display attribute of the first cell should
be table-cell, should it not?  That's what the HTML CSS says, at least.
(Assignee)

Comment 4

18 years ago
Fixed with recent checkins.

I'm CCing jst because he might known the answer to the last question. I think 
the cell must have its display set to table-cell but maybe the dom is not able 
to retrieve it for some reason.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 5

18 years ago
verifying using 2000062520 nightly on w2k
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.