NPNetscapeFuncs size change handled non-backwards compatibly in npunix.c

RESOLVED FIXED

Status

()

RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: wbardwel, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-05-05])

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20060211 Fedora/1.0.7-1.3.fc3.legacy Firefox/1.0.7
Build Identifier: 

The npunix.c file in ./modules/plugin/samples/default/unix/npunix.c has code which just fails if run under an older browser.  It refuses to initialize the function table if the size of the table passed in is smaller than the size of the NPNetscapeFuncs.  And the code unconditionally copies pushpopupsenabledstate and poppopupsenabledstate.  This means that compiling a plugin with that makes a plugin that won't work under older browser

Reproducible: Always

Steps to Reproduce:
1. build a plugin against npunix.c
2. run under older browser (like FireFox 1.0)
3. have plugin fail to initialize.



Expected Results:  
It should instead see if those functions are available, and if so copy them, if not don't.
(Reporter)

Comment 1

12 years ago
Created attachment 244834 [details] [diff] [review]
Patch that I am using to deal with this problem.

Comment 2

12 years ago
This is a result of Bug 301052.

Comment 3

9 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.4) Gecko/20100413 Firefox/3.6.4
Please update if you are able to still reproduce with the latest nightly build  ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk/
Whiteboard: [closeme 2010-05-05]
(Reporter)

Comment 4

9 years ago
It looks like the fix for Bug 301052 fixes this bug as well.  (It looks Firefox 3.0 and newer have a npunix.c that is fixed.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.