control sequence binding is broken in textareas on unix

RESOLVED DUPLICATE of bug 260572

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 260572
13 years ago
13 years ago

People

(Reporter: heas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.8.0.5) Gecko/20060731 Firefox/1.5.0.5
Build Identifier: Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.8.0.5) Gecko/20060731 Firefox/1.5.0.5

Unix control sequences were bound intuitively for textareas in mozilla, but are not in firefox.  The following no work:
 - ctrl-w = kill word before cursor position
 - ctrl-a = move to beginning of line
 - ctrl-e = move to end of line
 - ctrl-u = kill from cursor position to bebinning of line
 - ctrl-k = kill to end of line
 - ctrl-d = kill character following cursor
 - ctrl-f = move cursor forward 1 character
 - ctrl-b = move cursor backward 1 character
 - ctrl-n = move cursor to next line
 - ctrl-p = move cursor to previous line
(there are likely others)

The first of these is the worst, since it closes the current tab or window; and I actually did this twice while completing this bug report.  I know that other
tickets exist on this one.  The remainder is just bloody irritating.

Anyone who interacts with a unix shell must be familiar with at least these and
surely has been burned by or lost hair over the change in binding.

Reproducible: Always

Steps to Reproduce:
1.go to google.com
2.enter a word in the search text area
3.hit ctrl-w to erase the word...and the window/tab goes away
Think about how you'd like to put your fist through the screen.
Actual Results:  
 - ctrl-w = closes tab/window
 - ctrl-a = selects all of the text
 - ctrl-e = unknown
 - ctrl-u = opens the page source window
 - ctrl-k = unknown
 - ctrl-d = bookmark page
 - ctrl-f = find in page
 - ctrl-b = bookmarks
 - ctrl-n = new window
 - ctrl-p = print dialog
http://kb.mozillazine.org/Emacs_Keybindings_-_Firefox
bug 260188 and bug 260572 have some background info


*** This bug has been marked as a duplicate of 260572 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.