No way to set test case order in Test Run

RESOLVED FIXED

Status

Testopia
Test Runs
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Vashistha, Assigned: Greg Hendricks)

Tracking

x86
Windows XP

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

If i have 10 test cases in a test run and i want to add it in such a way that it is displayed after 5th test case in a Run.

Reproducible: Always

Steps to Reproduce:
1.Enter 10 test case
2.Create a run.
3.It will display all test cases in test run ordered by test case id.
4.Now enter 11th test case.
5.Create new run. It will display 11th test case after 10 though one has set dependency/blocks field.

Actual Results:  
Currently execution order is not set. It displays in same order in which one has entered test cases. There is no way one can inset test case in between.

Expected Results:  
As per dependency/Blocks field execution order will be set automatically in Run. So if test case with ID 2 depends on test case with ID 4 then 4th test case should appear earlier in list than 2nd test case.

It is very common that order of execution of tests is different from the order in which test cases entered.
(Reporter)

Updated

12 years ago
Version: unspecified → 1.1
(Assignee)

Comment 1

12 years ago
What we need is a way to sort by dependency. 

Comment 2

12 years ago
Can this be addressed in the next release?
(Assignee)

Comment 3

12 years ago
There are several issues that need to be addressed here. First, for a user defined sort order in which any case can come before any other, an efficient indexing algorithm would need to be developed so as not to impact performance on runs with large numbers of test cases. 

Secondly, a user interface needs to be designed that could all users to change the order without the need to move one at a time up the list. This would be ok for 10 test cases, but not 10,000. 

I am drawing a blank on both of these questions. The ability to sort on dependency would not be difficult by itself, but that is only half of what is wanted.
(Assignee)

Updated

12 years ago
Duplicate of this bug: 355308
(Assignee)

Comment 5

12 years ago
user entered sort key.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.