Problem with itemset referred to attributes of indexed elements

RESOLVED WONTFIX

Status

Core Graveyard
XForms
RESOLVED WONTFIX
11 years ago
2 years ago

People

(Reporter: Federico Gimenez, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.49 KB, application/xhtml+xml
Details
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

In master-detail views (for edit indexed elements) it is
not posible to edit attributes with itemsets for certain indexes. You
can select the label in the itemset but the value doesn´t reach the
atributte of the indexed element.
The problem can be solved dispatching 'Rebuild' and 'Refresh' with
XForms Buddy in detail view (that is, once the index is set).


Reproducible: Always
(Reporter)

Comment 1

11 years ago
Created attachment 244879 [details]
Test case

In master view you can add elements. For the second element added, the attribute doesn't get the value selected in the itemset of the datail view

Comment 2

11 years ago
looks like when it fails to set a value, we are running into a JS error during dispatchSelectEvent (JavaScript error: chrome://xforms/content/select.xml, line 873: elm.parentNode has no properties)

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

11 years ago
the elm.parentNode issue is gone, probably fixed by bug 360188.

But I notice when this fails I see the following error in the stdout console:
###!!! ASSERTION: Found more undisplayed content data after removal: 'context
 nsnull', file c:/ns50xforms/mozilla/layout/base/nsFrameManager.cpp, line 648

This would explain why we see the behavior that we do.  The assertion is keeping us from calling recalculate, revalidate, and refresh when an item is selected from the select control.  When this assertion doesn't happen, everything works correctly.  Now we just have to figure out if XForms is causing this assertion or not.
RIP xforms
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.