Closed Bug 359814 Opened 14 years ago Closed 9 years ago

Filters don't apply tags properly

Categories

(MailNews Core :: Filters, defect, major)

1.8 Branch
x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: obrien.terrence, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2006-11-04-03-mozilla1.8/thunderbird-2.0b1pre.en-US.win32.installer.exe

I've set up a series of filters to label and sort mail as it arrives.
Few days ago I noticed that the filters were not applying tags to incoming messages, I ran the filters manually and it tagged almost half of my inbox with "School" even though it shouldn't.
It only applies to messages with additional tags. it is not incorrectly applied to untagged items.
(ie. items tagged "work" or "personal" are now tagged "work / school" or "personal / school" but no messages that should have no tags are tagged "school")
It occasionally applies this tag to incoming mail, but filters are still inconsistently applying tags.

Reproducible: Sometimes

Steps to Reproduce:
1.Create several filters based on sender
2.ask filters to apply tags, color code to easily distinguish
3.issue arises with incoming mail and when manually running filters

Actual Results:  
Mail continues to be improperly tagged

Expected Results:  
Tags should be applied according to the rules set in my filters as opposed to randomly as it appears to be doing
Version: unspecified → 2.0
imap or local/pop3 messages?
pop, its pulling from my Gmail account
(In reply to comment #1)
> imap or local/pop3 messages?
> 

any luck with this?
latest build (11/28/07) of 2.0 seems to have stopped applying tags to incoming messages all together.
My filters add tags regularly and I haven't noticed any issues with 2b1 or 3a1 builds.

Just to be sure this is understood (and I realize it may not apply):  if you have multiple tags on a message, the color used is for the highest-precedence tag.

Exactly what is the filter that's failing?
As of the last few weeks TB hasn't been adding the tags to incoming messages at all.
I understand that it will default to the color of the highest precedence and is actually the only reason I noticed the issue.

Here is my list of filters, they are applied specifically to my email account and not to the local folders.


1. Name: Personal
Match all of the following.
From: is in my address book: Personal Address Book

Perform these actions.
Tag Message: Personal

2. Name: Work
Match any of the following.
From: Contains: ubs.com
From: Contains: itmmi.com

Perform these actions.
Tag Message: Work

3. Name: School
Match any of the following.
From: Contains: CUNY
From: Contains:CSI
From: Contains:tuition
From: Contains:AMS
From: is: *****.***@gmail.com
Subject: Contains: CSI

Perform these actions.
Tag message: School

4. Name: Events
Match any of the following.
From: Contains: ticketweb
From: Contains: ticketmaster
From: Contains: tix

Perform these actions:
Tag Message: Events

5. Name: Bills
Match any of the following.
From: Contains: customercare@nytimes.com
From: Contains: verizonbillpay
From: Contains: twcnyc.com
From: Contains: cingular
etc...

Perform these actions.
Tag Message: Bills

6. Name: Orders
Match any of the following.
Subject: Contains: order
Subject: Contains: confirmation
Subject: Contains: rebate

Perform these actions.
Tag Message: Orders


What happened before is that many messages (seemingly random, I was unable to spot a pattern) that should have been tagged personal or work were tagged with school in addition.
Though as of a few weeks ago TB has stopped applying tags altogether despite the fact that the filters are all enabled.

Was there perhaps a change in the TB handles the filters that would cause my filters to stop working since they're only applied to the account but not to the broader local folders where all my mail is stored?
(In reply to comment #5)
> As of the last few weeks TB hasn't been adding the tags to incoming messages
> at all.
>  [...]
> Was there perhaps a change in the TB handles the filters that would cause my
> filters to stop working since they're only applied to the account but not to
> the broader local folders where all my mail is stored?

I'm not sure what you're saying in the last part there; it seems to contradict the first sentence.
I see this in this circumstance:

Filter 1: if from is A or B or C or D apply tag Personal

Filter 2: if subject contains [List2] move to folder List2

Filter 3: if subject contains [List3] move to folder List3   etc.

Receive a message from person A on list [List2]

Filter 2 works and the message gets moved to the folder List2. But Filter 1 doesn't apply the tag (most of the time if not all). 

However, if the filters are run manually, the tag in Filter 1 gets applied AND Filter 2 runs and moves the message to folder List2. But the filter log only shows Filter 2 as having run, not Filter 1, even though both did. 

This is with version 2 beta 2 (20070116) WinXP.
Hi all!

I've got this problem as well, so when the mails were fetched by TB the tag options in message filter don't execute automatically.

But if I run the filters manually, it's tagging the mails.

Thanks, bye
Thunderbird 2.0 beta 2 on Windows:
Filters with Tag then Move to folder

The emails are moved to the folder but they are not tagged. Instead a single message in the Inbox is tagged, this message is unrelated to the rules, but it was the first email message received in the inbox folder (and it is not the oldest).

This message gets tagged with a single tag when the filters run.

Hope this helps finding the bug.
Could this be the same as bug 369745?  I think at least some of these reports are...
See bug 366503 -- there's a patch for that on the trunk now and awaiting approval for 2.0.  
Bug 366503 has been fixed for 2.0.  Is this bug still present with current builds (that is, later than Feb 26)?  If it's been fixed, please mark this bug as a dupe of that one.
I still have it with 20070326.

As I understand bug 366503, the tags were getting clobbered if the message had a junk status. Or tags weren't being properly written if they had a $ in the definition. 

Anyway, looking at X-Mozilla-Keys, the tag is getting properly written there. But the effect of the tag is not being displayed. 

I have 2 filters set up for testing:

1. If message is from <these people> Tag message as Important
2. If message subject line contains [MailList] Move message to MailList box

When Tbird gets mail (POP3), it applies $label1 (for Important) in the X-Mozilla-Keys tag AND the messages are moved to the MailList box  BUT they don't display as red with the Important tag. And Important doesn't show up checked on the drop-down tagging menu.

The filter log shows that the Move filters were applied but doesn't show that the Tag filters were applied. 

However, if I manually run the filters on the folder, the tags display correctly. 

In fact, if I take the messages that were moved by the filters, manually move them back to the Inbox, clear the tags, and manually run the filters, the messages get moved AND tagged AND displayed properly. Even though the message source isn't any different from what was there originally. 

Here's one more thing. I have a message that I received that both filters should have been applied to. It was moved, and X-Mozilla-Keys contains $label1, but the Important tag doesn't display, and it doesn't show up as checked in the drop-down tagging menu. Now I manually tag the message as To-Do. X-Mozilla-Keys now contains $label1 and $label4. The message displays as blue (for To-Do, not red for the Higher-priority Important) and in the tagging menu, To-Do is checked but Important is not. I manually untag To-Do. X-Mozilla-Keys still contains $label1, but it is not displayed in red with the Important tag and the check box in the drop-down tagging menu isn't set for Important. 

So there's something different happening when Tbird fetches mail and applies filters than when it applies filters manually. And if the tagging is keyed off the X-Mozilla-Keys tag, that tag is being correctly insert in X-Mozilla-Keys in either case. So it's something other than that tag, which was the issue in the  bug 366503. Wherever the tag status is stored, it's not getting picked up properly. 

Hi,

I agree with David E.B. Smith because I have the same problem.

The curious one is that I have two account in my Thunderbird 2.0.0.0 (20070326), one IMAPS and one POP3S. In my IMAPS account, the tag message filter is working and in IMAPS account isn't!

I am experiencing the same problem.  I am running TB 2.0.0.0 20070326 on Windows Vista Ultimate.
After consulting bug # 377541, I turned off the option to allow anti virus software to more easily quarantine emails.  My tags are now applied to incoming mail.
To Terrence O'Brien(bug opener):
Bug 377541 pointed by Kevin in comment #16 is closed as DUP of Bug 355537. 
Do you enable "allow antivirus clients to quarantine individual messages" option?
If yes, you are possibly looking problem of Bug 355537.
alessandro, David E.B. Smith, does this still fail in 2.0.0.6 ?

(Terrence is apparently gone)
Message Filters / Address Book & Tags not working

Thunderbird Version 2.0.0.9 (20071031)

I've also been suffering this problem.  Tags do not get applied to Messages when the Conditions Box includes an Address Book.  This problem doesn't exist with the new tentative Thunderbird trunk Version 3 (dated December 22nd).

Reproducible: Always

Steps to Reproduce:
1. Create a Message Filter that stipulates ALL of the following conditions:
    From / is in my address book / Personal Address Book
2. Stipulate the following Action:
    Tag Message / Personal
3. Create another Message Filter that stipulates ALL of the following conditions:
    From / isn't in my address book / Personal Address Book
4. Stipulate the following Action:
    Tag Message / Important

Actual Results:
The respective Tag is not applied to the affected Message.

Expected Results:
The Tag should be applied to the affected Message.
Assignee: mscott → nobody
Test STR (steaps to reproduce) in comment #19 with:

1. TB 2.0.0.23 and work fine!

2. work fine also with latest 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6pre) Gecko/20091108 Shredder/3.0pre ID:20091108032229

Terry (and hoters that are affected of this issue) should update to last 2.0.0.23 release (o to the 3.x beta).

I think that this bug should be close as WFM... Wayne?
I can't speak to v2. I haven't had trouble in v3.
Terrence, David, Alessandro, Kevin and Terry: with my test using TB 2.0.0.23 your issue WFM (work for me).
Could you try if is equals for you using last 2.0.0.23?
Whiteboard: closeme 2009-11-26
I have the latest version 2.0.0.23 (20090812), but the Tags still don't get applied.  If you run the Filter MANUALLY, they will get applied.
Whiteboard: closeme 2009-11-26
(In reply to comment #23)
> I have the latest version 2.0.0.23 (20090812), but the Tags still don't get
> applied.  If you run the Filter MANUALLY, they will get applied.
I don't run filter MANUALLY... Terry could you try if this issue still exist in 2.0.0.23 when safe-mode is running?

see here http://kb.mozillazine.org/Safe_mode
I have the latest version 3.1.1, but the Tags still don't get
applied.  I don't see why this problem hasn't been fixed.
(In reply to comment #25)
> I have the latest version 3.1.1, but the Tags still don't get
> applied.  

seems odd, given your comment 19.

Is this only seen with pop accounts?


> I don't see why this problem hasn't been fixed.

because (it seems like) the exact conditions which cause the problem havn't been agreed to, aka no one in a position to fix this can reproduce.
I use "Fetch headers only" in Account Settings / Server Settings.  Try that setting, and see if you then experience the problem explained in Comment 19.
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Version: 2.0 → 1.8 Branch
comment 19 works for me with current trunk and fetch headers only
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
This problem has not been fixed.  I have Thunderbird Version 3.1.8 (20110221).
You need to log in before you can comment on or make changes to this bug.