If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

error in pop-up when url with parameters is used in window.open

RESOLVED DUPLICATE of bug 242656

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 242656
11 years ago
11 years ago

People

(Reporter: Luc Dierikx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: Firefox 1.5.0.7

1)Failure occurs in Firefox. Not in IE.
2)When the url which is used in the window.open is pasted directly in the browser it works fine in Firefox.
3)The application is built with visual studio. If the html of the ZoekClub.aspx
is paste to the desktop and the url is paste in the Firefox browser it works fine.
4)On the asp.net site www.happyhome.nl the same functionality is used and works fine.
5)When the page http://www.voetbalroute.nl/ZoekClub.aspx is copied to a Frontpage web the error doesn't occur in Firefox.

Reproducible: Always

Steps to Reproduce:
1.http://www.voetbalroute.nl/ZoekClub.aspx?Club=slot <enter> in Firefox
2.push the "Toon route" button and the error occurs.
3.

Comment 1

11 years ago
As far as I can tell the target website (locatienet.com) checks for a referrer and will fail to load if one is found. This is done server side.

If you load the website from a local place no referrer will be send. This is why it works if you enter the url in the location bar or use ie. In both cases no referrer is sent. I believe it is intended behaviour to have window.open() send a referrer.

Could you perhaps add a highly reduced test case, with both the script of voetbalroute.nl and happyhome.nl.
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> As far as I can tell the target website (locatienet.com) checks for a referrer
> and will fail to load if one is found. This is done server side.
> If you load the website from a local place no referrer will be send. This is
> why it works if you enter the url in the location bar or use ie. In both cases
> no referrer is sent. I believe it is intended behaviour to have window.open()
> send a referrer.
> Could you perhaps add a highly reduced test case, with both the script of
> voetbalroute.nl and happyhome.nl.

I don't understand exactly what you mean with 'a highly reduced test case.'
I stripped the zoekclub.aspx to zoekclubstripped.htm and put this on the site.
Try http://www.voetbalroute.nl/zoekclubstripped.htm

On the site of happyhome the same functionality is used and works in Firefox all right.
When I get the source code and put the code it in mine site it fails in Firefox.
The code in the happy home site uses <a href="#" onclick="var oPop=window.open(url + paramaters)



Comment 3

11 years ago
Happyhome uses as far as I can tell it not the same way to build the URL, but has, I think, a paid relation with locatienet.net. It doesn't use a zip code plus country code, but some obscure number. 

The reason why your just submitted testcase fails is because locatienet has built in a security system to prevent unpaid use of it. It checks for a referrer, which IE does not send for window.open() and Firefox does. This is intended behaviour.

A reduced testcase is like you provided (although it still contains a bit of unneeded code). But with the working version of happyhome.nl on the same page. Then we can exactly see where the problem comes from.

As for now, this bug should most likely be marked INVALID. Sending referrer information with window.open() is intended behaviour.

Comment 4

11 years ago
Thanks for diagnosing this, Paul.

*** This bug has been marked as a duplicate of 242656 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.