missing navigator entities in navigator.dtd

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
P3
blocker
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: jon rekai, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
w32 build 041605 missing entities previously found in navigator.dtd- 'undefined
entity error dialog prevents loading moz:

from navigator.xul:
<menu>
 <titledbutton id="sessionhist-popup"/>
 <menupopup>
 <menuitem value="&quoteKeyword.label;" oncommand="setKeyword(0)"/>
 <menuitem value="&localKeyword.label;" oncommand="setKeyword(1)"/>
 <menuitem value="&shopKeyword.label;" oncommand="setKeyword(2)"/>
 <menuitem value="&careerKeyword.label;" oncommand="setKeyword(3)"/>
 <menuitem value="&webmailKeyword.label;" oncommand="setKeyword(4)"/>
 <menuitem value="&listKeywords.label;" oncommand="setKeyword(5)"/>		 </menupopup>
 </menu>

from previous navigator.dtd, missing from current:
<!ENTITY quoteKeyword.label           "Get a quote">
<!ENTITY careerKeyword.label          "Get a job">
<!ENTITY shopKeyword.label            "Shop Online">
<!ENTITY webmailKeyword.label         "Check your email">
<!ENTITY localKeyword.label           "Local Information">
<!ENTITY listKeywords.label           "List of Keywords">

Comment 1

18 years ago
Exactly which build was this in? [I also got bit by this, but I couldn't find
a mozilla build with this problem].

At any rate, I see that these entities are checked into the tree (in 
navigator.dtd). Passing to radha, although this may have been a transient
problem with packaging up the correct bits.
Assignee: asadotzler → radha
Status: UNCONFIRMED → NEW
Component: Browser-General → XPApps
Ever confirmed: true
QA Contact: jelwell → claudius
(Reporter)

Comment 2

18 years ago
w32 build 041605...  2000041605 - it's in /pub/mozilla/nightly/2000-04-16-06-M15
(0620 ts on the zip).  dir name doesn't quite match the build id on the status
bar.  the most recent files in zip are dated 04162000 05:56.  adding the
entities to the .dtd seemed to correct the issue:)~

Comment 3

18 years ago
*** Bug 36068 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
Setting to blocker (can't launch the browser). 

Two notes: 
1) there is a workaround (add the entities noted above to navigator.dtd
2) this looks like a packaging issue, since the trunk copy of navigator.dtd
   does contain these entities AFAICT.
Severity: normal → blocker
Summary: missing navigator entities → missing navigator entities in navigator.dtd

Comment 5

18 years ago
yeah, running out of the tree works fine, except the commercial build, which
doesn't run for some other xml parsing error.
I'm guessing, this problem occurs only in M15 builds. somehow, M15 builds picked 
up the xul file and not the dtd file ? This feature was meant for M16 and not 
for M15. Leaf, granrose, can you throw some light on how this can be resolved?

Thanks,

Comment 7

18 years ago
Actually, radha, it's the reverse: I choke on the XML parse for 
  win32  2000-04-17-09-M16 commercial
  linux  2000-04-17-11-M16 commercial
  macos  2000-04-16-08-M16 commercial (no apr 17 build is out yet)

Comment 8

18 years ago
Note that the entities are there in navigator.dtd for the *mozilla* tree.
(I need to brush up on my CVS skills in order to check the commercial tree :-])

Comment 9

18 years ago
i've fixed this in the ns/ tree, i think. respinning today's commercial builds.
this is probably a case of the mozilla file being updated, and the corresponding
change not being made in the ns/ version.
sorry & thanks guys. I will teach myself to watch out for such things in the 
future.
Is this still a problem?
Status: NEW → ASSIGNED
Target Milestone: --- → M16

Comment 12

18 years ago
Since all M15 and M16 builds launch on mac/linux/win32, then the correct 
entities are contained in the commercial bits (navigator.dtd). 
Marking WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 13

18 years ago
marking VERIFIED with 20000418 builds
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

18 years ago
app launching fine now w95, nt4...  launching

Comment 15

18 years ago
ha! i checked in the fix john morrison suggested, this should be closed, fixed.

Comment 16

18 years ago
oops ...
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 17

18 years ago
... a 'kill' for leaf ...
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 18

18 years ago
vrfy
Status: RESOLVED → VERIFIED
(Reporter)

Comment 19

18 years ago
it's baaaack- w32 build 2000041905. entities missing from .dtd:

<!ENTITY quoteKeyword.label           "Get a quote">
<!ENTITY careerKeyword.label          "Get a job">
<!ENTITY shopKeyword.label            "Shop Online">
<!ENTITY webmailKeyword.label         "Check your email">
<!ENTITY localKeyword.label           "Local Information">
<!ENTITY listKeywords.label           "List of Keywords">
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 20

18 years ago
Putting on nsbeta2 radar.
Keywords: nsbeta2

Comment 21

18 years ago
This is fixed, no? (I didn't see any resurrection of the problem that 
was described on the reopen -- all of today's comm. builds contain these 
entities, and the moz builds would not start unless these were included).
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 22

18 years ago
resurfaced in that one build, 2000041905 m15.  the 2000042008 m16 win 32 and 
2000042108 m16 win32 builds do contain the entities.
per reporter's comments (and my own tree) marking wfm.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.