Bookmarks Aren't Deleted from Bookmarks Menu After Deletion from Bookmarks Manager

RESOLVED FIXED in Camino1.5

Status

Camino Graveyard
Bookmarks
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Hayden, Assigned: Stuart Morgan)

Tracking

({fixed1.8.1.1})

unspecified
Camino1.5
PowerPC
Mac OS X
fixed1.8.1.1

Details

Attachments

(3 attachments)

128.96 KB, image/jpeg
Details
66.26 KB, image/jpeg
Details
fix
1.79 KB, patch
Håkan Waara
: review+
Mike Pinkerton (not reading bugmail)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061106 Camino/1.1a1+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20061106 Camino/1.1a1+

Bookmarks deleted from the bookmarks panel are not deleting from the bookmarks drop-down menu.

I suspect that it may be related to the corrections made in result to bug 359662 https://bugzilla.mozilla.org/show_bug.cgi?id=359662 however I can't confirm this.

Reproducible: Always

Steps to Reproduce:
1. Click 'Show All Bookmarks'
2. Delete A Bookmark
3. Exit Bookmarks Panel
4. Click Bookmarks Drop-Down Menu



Expected Results:  
It's expected that bookmarks deleted from the bookmarks panel would also delete from the bookmarks drop-down menu.

Example appended.
(Reporter)

Comment 1

11 years ago
Created attachment 244976 [details]
Screenshot of Bug

You can see where the bookmark has been removed from the bookmarks panel, but still appears in the bookmarks drop-down menu.
(Reporter)

Comment 2

11 years ago
Doesn't seem to happen every time.
(Reporter)

Comment 3

11 years ago
Created attachment 244977 [details]
Screenshot of Bug 2

Bookmark 'Seven Reasons the 21st Century is Making You Miserable' has been deleted from the bookmarks panel, but still appears in the bookmarks drop-down menu between 'TheStar' and 'strange maps'

Comment 4

11 years ago
I'm not sure how related this is to bug 359662 (other than by the fact that we build the bookmarks menu lazily, which is on purpose).

From what I can see, the menu is being updated correctly when creating, moving, or copying bookmarks, but not when deleting.

This doesn't seem to occur in 1.0.3, so confirming as a regression and tweaking summary to use the standard terminology.
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Summary: Bookmarks Aren't Deleting from Drop-Down Menu After Deletion from Bookmarks Panel → Bookmarks Aren't Deleted from Bookmarks Menu After Deletion from Bookmarks Manager
Target Milestone: --- → Camino1.1

Comment 5

11 years ago
"related to the corrections made in result to bug 359662"

I need to read more carefully.  It's absolutely not that, since that bug hasn't landed yet.
(Assignee)

Comment 6

11 years ago
Off the top of my head, hwaara's work to optimize bookmark deletion might be a good first place to look.

Comment 7

11 years ago
Can someone come up with a 100% reproducible & simple testcase for seeing this bug?

Comment 8

11 years ago
This is 100% reproable for me with these steps:

1. Cmd-B.  Make sure you're looking at the bookmarks menu collection
2. Option-drag an existing bookmark to duplicate it.  Examine the bookmarks menu (both bookmarks are visible)
3. Hit the delete key.  Examine bookmarks menu.

What happens: Still displays duplicate bookmarks.
(Assignee)

Comment 9

11 years ago
Created attachment 245269 [details] [diff] [review]
fix

This was a latent bug triggered by the fast-deletion changes; the bookmark menu has apparently never handled the childen-changed notification.
Assignee: nobody → stuart.morgan
Status: NEW → ASSIGNED
Attachment #245269 - Flags: review?
Comment on attachment 245269 [details] [diff] [review]
fix

Håkan, can you look at this soonish?
Attachment #245269 - Flags: review?(hwaara)

Comment 11

11 years ago
Comment on attachment 245269 [details] [diff] [review]
fix

Looks good!
Attachment #245269 - Flags: superreview?(mikepinkerton)
Attachment #245269 - Flags: review?(hwaara)
Attachment #245269 - Flags: review+
(Assignee)

Updated

11 years ago
Attachment #245269 - Flags: review?
Comment on attachment 245269 [details] [diff] [review]
fix

sr=pink
Attachment #245269 - Flags: superreview?(mikepinkerton) → superreview+
(Assignee)

Comment 13

11 years ago
Checked in on trunk and MOZILLA_1_8_BRANCH.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: regression → fixed1.8.1.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.