While page is loading, pressing Enter in location bar opens new tab in background

RESOLVED WORKSFORME

Status

()

Firefox
Address Bar
--
major
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: Timwi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

While a page is loading, typing a new address in the location bar and pressing Enter in location bar opens a new tab in the background.

This is a severe UI failure because:
(1) it is inconsistent and unexpected, and therefore mustn't be default.
(2) all available "load-in-background"-related options in Tools => Options and in about:config are set to "false".
(3) the typed-in address remains in the location bar even though the old webpage is still showing.

Reproducible: Always

Steps to Reproduce:
1. Type the address of a page that takes longish to load, and press Enter.
2. While the page is still loading, type another address and press Enter.
Actual Results:  
A new tab is opened in the background with the URL typed in.

Expected Results:  
The current tab stops loading the old website and starts loading the new. (Firefox 1.5 behaviour.)
(Reporter)

Comment 1

12 years ago
Further investigation shows that the "Tabbrowser Preferences" extension causes this behaviour.

I don't know if the problem is in Firefox or the extension, though, so I'll leave the bug open.

Comment 2

12 years ago
Unless there's reason to assume the contrary, extension related issues aren't considered bugs in Firefox but in the extensions themselves. Should this be an exception, please upload a simplified testcase and reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.